Asset manager disappearing and issues

I was working on a project in Blocs 4.1.1. under Catalina 10.15.7 when I reopened the project I got a message stating the a specific image could not be found. I was able to successfully point to its location.
A few minutes later I wanted to import a couple of new images but the Asset manager would not load either from the icon tab or Cmnd 7.

The blue icon turned on and off but nothing loaded. I restarted everything and the missing image message did not appear nor did the Asset mgr. All the images were visible in the project and in my external file. You could click on the project image and all appeared normal.
The images are stored on an external 6 TB thunderbolt 3.1 drive and imported into Blocs and no second monitor.

After several more Blocs saves and restarts the missing image message reappeared. This time I deleted the image and the asset mgr has reappeared & for now things are back to “normal”.

I put normal in quotes because occasionalIy I get a missing photo error msg and when I try to relink it, I would get a message stating that it is already in the manager. So I would have to delete it and rename it and reimport it.

I am not a programmer so I do not know how doing several restarts fixes this issue as opposed to one. There are 200 images in this project so it causes me a great deal of concern.

Have you solved this yet etdronehome? I have it too. I’m going to try reinstalling Blocs to see if that works.

I am not having this issue any longer but other than restarting Blocs and my iMac I did not do anything that could help you. Sorry I could not be of any help.

That worked for me. Lord knows what it was.

I am glad that it worked. I have noticed shutting down all the apps individually and restarting the system has cleaned up strange intermittent issues in FCP, LR CC and PS. I have 32G on this machine.