Asset Manager Gone

I have no asset manager window appearing in blocs. Doesn’t matter which way I try to bring up the window, it simply can’t be seen. Blocs is saying the manager is open but I have nothing to use. Tried reboot and nothing.

Thanks

magically showed up after 4 reboots

I am not longer able to see the Asset Manager. Whether I click in an image, the property column at right, or the icon below, or the Menu item. Nothing happens – so, I can’t add images.

I’ve had this problem a couple of times, but each time I would just restart Blocs and it would reappear. Now, no matter what I do it won’t appear.

I rebooted, without success. I just saw this post which suggests rebooting 4 times may be necessary – really?

Then I decided to download the current beta and the Asset Manager worked right away. But still not with my current version.

Is there a (reasonable) fix for this?

Current version: 3.4.5
Beta version: 3.4.6 build 2

Do you use a separate monitor?

It may be off screen

First, it’s impressive that you guessed I had a separate monitor. I do. It’s a nice laptop whose screen is broken so I cannot see what’s on it. It works so well in every other way that I forget about that.

Second, for some reason when I went to test just now the Asset Manager appeared again.

So, I don’t understand why it’s back now, but thanks to your help I know something to try next time --> I will play with the Monitor settings, probably use the “duplicate on each monitor” setting, to see if that was the problem.

Thanks!

Yeah, it’s usually the case, when external monitors are attached (the window management gets messed up, on occasion).

Glad you are all sorted.