/. at the end of URL

Not sure why but some URL’s or links are being pricked up by seo crawler like this when using Clean URL’s:

https://www.example.com/hello/.

instead of

https://www.example.com/hello/

Anyone else got this issue?

Really? where are you seeing that? I’ve just checked half a dozen sites and not seen this.

Yep, I’m sure its an issue with Blocs, I wiped my .htaccess and it was still doing it. Restored my .htaccess and then changed ‘Navigate to Page’ to ‘Navigate to URL’ and its not showing the errors anymore.

Try this tool and see what comes back: https://www.internetmarketingninjas.com/seo-tools/google-sitemap-generator/

Before (you can see the arcacia/.)

After (I did this on 5 links and it removed the /. from the end)

Also had it happen to me in Scrutiny sometimes too when exporting

OK now I am seeing this as well when I search at the same site, but I’ve not noticed it with Scrutiny. Are we sure it’s not this website checker? How are you adding your URL at this site and in Scrutiny? I always add a trailing slash.

Could @Norm take a look here.

The pages are effectively appearing twice:

screenshot_1304

I’ve definitely seen this in Scrutiny. I have tried with the trailing slash and without, both same results.

I’ve noticed in when generating XML Sitemaps too, specifically using this one which I presume is the most popular: https://www.xml-sitemaps.com

I’ve had to go through and remove the URL’s with a full stop at the end as its incorrect and essentially a duplicate.

I’ve now changed all URL’s to proper URL’s instead of by page.

If one of us tries contacting Shiela I bet she will be able to spot what is going on here. She’s the developer of Scrutiny and very clever at spotting bugs in web code that lead to errors. I’m just surprised this hasn’t shown up on any other test sites though if it is a problem.

N.B just a thought, but it would be interesting to compare settings in Scrutiny, because that may give us a clue to what is going on.

I haven’t took a chance and re-done all my URL’s. Was getting 37 redirects, now getting 0 with not 1 broken link anywhere.

1 Like

We have identical option settings. I am not seeing those /. in Scrutiny. I’m using version 8.3.8.

I’m not seeing them now but I’ve 100% seen them, using 8.3.7

Hmm, I’ve just tried on that site again with a website done in Rapidweaver and that /. 301 doesn’t appear. I think Norm should take a look at this.

1 Like