Bloc 3.4.5

@Norm Have you had any problems with links on the new version? I opened Blocs and updated my app. I tried adding a login text link, then a button and the links will not work. Opened another site and the same thing happened?

Link to site with a login button at the bottom of the page.
https://melisastreasures.com/index.html

Casey

I’ve not had any reports of this no.

Could you send me a copy of the file please and I’ll take a look.

@norm It seems as if the latest update (3.5.4) isn’t accepting code. I’ve added a code bric, pasted my code (which has always worked before) and it no longer displays the content on the page in preview, or after publishing. There is nothing else on the page. The code is shown below:

<link href="https://rmbookings.trisel.website/rmscript/core/framework/libs/pj/css/pj.bootstrap.min.css" type="text/css" rel="stylesheet" />
<link href="https://rmbookings.trisel.website/rmscript/index.php?controller=pjFrontEnd&action=pjActionLoadCss" type="text/css" rel="stylesheet" />
<script type="text/javascript" src="https://rmbookings.trisel.website/rmscript/index.php?controller=pjFrontEnd&action=pjActionLoad&tab=service"></script>

Norm, I moved the button up 30 pixels from the bottom of the page and it’s working. I have a floating button and I’m wondering if that may be conflicting with the button. I’m heading out the door and I’ll send you the file later. Re-click the link I sent and you’ll see the button is now working.

Casey

The code exists in the page, what is it supposed to do?

Also dont forget to turn off in app preview for the code Bric, as the webkit engine will escape characters that are rendered in app.

I checked and some get escaped if preview is left on.

Try this:

• Disable preview on the code widget.
• Paste in your code again (as it is likely escaped now)
• Preview

That could be it, try using the layer tree to make the selection rather than the canvas.

Hi Norm, The code is supposed to display a booking calendar as seen on THIS page. The linked page was created with another app as a temporary solution (which isn’t ideal of course). I turned off the code preview option as I do with most code - just in case. In fact, the code itself can be added to any site and it should work ok, so feel free to copy and paste it into a blocs project and preview it in a browser.

If you right click and inspect when in preview mode you can see there are 4 errors, most notably.

Origin http://localhost:8080 is not allowed by Access-Control-Allow-Origin.

Cross origin is a security measure, not something I can get around. I wonder if compiling with a newer version of Xcode has moved some security measures to fall in line with recent changes in Catalina.

I just checked on my server and it doesn’t work unless its run on the your server because of CORs.

Ok, I’ll check it out - thanks for taking a look

1 Like

no worries :+1:

Got it one @norm. That’s exactly what the problem was - many thanks. :grinning: :grinning: :grinning:

1 Like