Blocs 2.5.0 Beta Build 3


#1

Blocs 2.5 beta build 3.

New In This Build - Highlights

• Added a bulk import for hosted assets, just paste in your string and then choose the separator ie \n for new line and Blocs will do the rest.

• Added smart search for the Asset Manager search, start search query with @ followed by group name to show group contents. After the group name add : then search term to search that group for search term, for example @photos:mountains will show all mountain images in the photos group. You can also use @hosted to show all hosted assets.

• Added support for dragging assets to the sidebar image wells.

• Added function to synchronise all light box frames per gallery ID.

This release also fixes a nasty bug that caused Blocs to break when duplicating to another page as well as some other long standing ones.

EDIT: Build 3 has been tweaked to fix bulk import issues. Re-download.

Outstanding Issues
• Some users are experiencing images not loading in asset manager.
• Potential tooltip issue.
• UI rendering issues on MacOS Yosemite.


So here it is folks Blocs 2.5. This release includes lots of new features and fixes. The biggest one of course is the new Asset Manager. I’ve pulled together some notes that you need to read before you start using this versions as files saved in 2.5 will not load all new asset data in older versions of Blocs.


Important Read Me

Blocs 2.5 replaces the old Asset Manager (the only remaining part of the app from Blocs version 1) with a new and improved one. There are lots of benefits to the new Manager but there are also some important things you need to be aware of before you use this beta.

File Data Structure
The data structure of files saved in Blocs 2.5 is different to previous versions. Any changes made in Blocs 2.5 regarding project assets will not be reflected if you open the project up in a version before 2.5. So adding new assets, removing them and grouping them will have no effect when you open the file in a version of Blocs before 2.5. This is because Blocs 2.5 writes a new data structure to the Blocs file that previous versions of Blocs can’t read.

You will need to make backups of your work before you use Blocs 2.5 and only these backups as once a file is changed and saved within 2.5, the changes made to the asset data structure will not be loaded in older versions of the app.

What Happens to the old asset data structure?
That will remain within the file so if you do go back to an older version of Blocs your original data structure will still exist, but it wont include any changes you may have made to it within 2.5.

Groups
One of the main new features in the new Asset Manager is the grouping function. You can create your own groups and all assets can be added to multiple groups, including the stock images. Please note, at this time groups cannot be nested within other groups, grouping is one level only.

Basic Notes

Select All - Hold command when clicking the select button to select all assets within a group.

Pattern Group - Any image asset added to the pattern group will automatically have its style value set to repeat when applied to a bloc background.

Tile Background Colour - If you add an image that has a transparent background and requires a light background colour. This can be set by right clicking the asset tile and selecting a light or dark background colour.


Ok so you know you need to use project backups with 2.5 and new Asset Manager data wont be read by the old the Asset Manager :sunglasses:

Oh and don’t forget to hard reload the beta page incase your cache blocks it.

Download Blocs 2.5


Dev API
For those of you who are interested in the developer API, its coming Im just finishing the Docs and basic resources to make it easier to get started. Hopefully things should be ready in a week or so.


#2

@Norm I’ve been getting on well with beta 2 and just checking out beta 3 now. I think some clarification is needed within the interface to explain how bulk hosted assets can be added, even if it means forcing us to adopt a specific syntax prior to import. I’ve tried a dozen options here and nothing has worked so far. With Yummy FTP Pro there is a space between each url and if you paste them in text wrangler, each one shows up on a different line.

EDIT: I’m not sure the bulk remote assets is working. If I try to add one image via the bulk uploader it works fine, but with more than one it won’t recognise the urls as valid. I’m typing " \n" for the separator, but I’ve also tried guessing other options

On the smart search feature how does this work? Do we need to give the files relevant names or can it pick up keywords in the metadata for example, which would be helpful.


#3

I tested the bulk importer and it worked fine for me in various scenarios. It’s imported that you put the correct character in for the separator. Don’t put the space at the start of the new line. Try just ‘\n’.

Smart search just lets you filter groups without switching to them via the drop down. It filters based on the file name.


#4

I’m just copy pasting as it comes out of Yummy and it doesn’t work that way. I also tried copying it first to text wrangler before pasting in Blocs, but that failed as well.


#5

Interesting. Could you send me a list direct from yummy saved as a text doc via DM please.

I’ll take a look.


#6

I’ve found another problem. If you click the orange button in the asset manager, so it goes down to the dock there is no way of accessing it again without quitting and restarting Blocs.


#7

I found that if you click the asset manager button (twice), it comes back.

Right-clicking Blocs in the doc or drop-down window menu and selecting asset manager pops it up for second and then it goes away.


#8

I don’t get that in High Sierra… it just the window in the dock and if I click it it returns to its location.


#9

Ok I have it fixed, it turns out to be when you input the \n macOS naturally escapes it so it looks for the separator \n which doesn’t exist. When I did all my tests I had the new lines written into the strings which meant they matched as they were escaped.

Anyway long story short, it’s fixed and I’ll update the build link with the micro fix included in the morning :sunglasses:

EDIT: In the meantime you can get your bulk strings to work by manually adding \n as the seperator between the URL’s in a minified string ie my-url\nmy-url2\nmy-urls\n


#10

Not here. If I click on the asset manager in the dock I can’t get it to reappear. Looking at it again I can access it by right clicking show all windows and then click on the asset manager.


#11

odd. Have you tried a restart, it may be the OS being a tinker.


#12

Not yet I’ll give it a go. I just tried it in El Capitan and it worked fine there. I have HyperDock installed on both machines, but I’m seeing different behaviour here on High Sierra.


#13

I’m not getting it as a separate Dock item 10.12.6. If I right click Blocs in the doc and select Asset Manager, it pops up and then goes away. If I select the Window Menu>Asset Manager, it pop’s up for a second and then goes away. The only way I’ve been able to get it back is to select the Asset Manager button (sidebar) twice.


#14

Double clicking the asset manager button inside Blocs works for me as well, but there appears to be some inconsistency for different users when attempting to recover it from the dock.


#15

Build 3 has been tweaked so the bulk importer should work now.

Window issue.
Do you get the same behaviour with the current release of Blocs 2.4.5?


#16

Thanks, I’ll download that now. I’ve just tested the window issue in 2.4.5 and the asset manager pops up if I select it from the dock, however it disappears within a fraction of a second. Further attempts yield nothing, so I either have to double click the asset manager inside Blocs as teeters indicated or restart Blocs.


#17

@Norm Confirmed that bulk importer now works. Wondering if there is an easier way for users to add images without having to type in “\n”. It’s OK once you know, but zero indication for new users.

Could this be automated or at least highlighted within the interface somehow? I understand the wish to keep a clean interface, but it shouldn’t require a Google search to find the answer.


#18

So its not just related to 2.5. What if you deactivate that dock plugin you have running?


#19

I hear you, leave it with me.


#20

I’ve deactivated Hyperdock and restarted Blocs, but it’s still happening. I’ll try restarting the computer incase something is sticky.