Blocs 2.6.0 Beta Build 6


#1

This update was getting pretty big so it’s been bumped up to version 2.6.0. This build fixes a bunch of issues with local web fonts, Pulse 5 template exporting and a few other bits and pieces.

The process of installing local web fonts is covered here.

Build highlights

• Added support for woff2 font files.
• Added support for multi file local font import.
• Improved hosted web font UX. If Blocs starts without an internet connection and then receives one while Blocs is running, hosted web fonts such as Google fonts are loaded into the design environment without the need to restart Blocs. When there is no internet connection, Google fonts are now greyed out in the font dropdown.
• Fixed various issues with Pulse 5 template export support.
• Fixed issue that prevented removing page head attachments via Missing Assets Manager.

Download Blocs 2.6.0


Pulse 5.1 🔥
#2

Excellent work @Norm.

As always congratulations for your dedication and energy transmitted to BLOCS.

Follow so you have all our strength with you


#3

I’m seeing something strange where I tried animating a header and then decided against it, but now the animation won’t go away, either when previewed on Blocs or after uploading to the server. It clearly shows in the side panel there is no animation, but the code of the exported site proves the animation is still active.

Blocs has been closed, saved and restarted various times but the problem persists. You can see the draft of the site at https://liubliu.co.uk/fictive/index.php where the names will fade in, but this screenshot shows it’s set to not include animation and this is happening on all three names.


#4

I’m very exited about the local font import – great feature, thank you so much! But there is a problem: I built a small test page, where I used local fonts, which I installed in Blocs before. Exporting the project, everything seems ok – Blocs creates a directory named “Fonts”. The file style.css refers to the font-files. But the fonts don’t show up in the page, if the files are uploaded to the web. You can see it here: www.bartolain.de/mysite


#5

Have you selected your chosen font again inside the project settings? A restart of Blocs may also be necessary. I have it working fine with the previous beta here https://rhythmic-learning.co.uk but I have yet to try with the b6.


#6

If an animation gets stuck, just delete the item and re-add it.


#7

Are the fonts files included in the fonts directory after export?


#8

That seems to have worked, but it begs the question why was it stuck. I often find that it’s quicker to delete something and start again, rather than troubleshoot but these are the sort of issues I’m hoping will be really ironed out when Blocs 3 arrives.


#9

The main problem with issues like this, is the fact that they are rarely consistent, which makes them really hard to replicate and fix. If you find the problem again, try to replicate the issue, if you can send me the steps and I’ll almost certainly be able to fix it.


#10

I’ll try to see if I can recreate this. I messed around with a few options and at a guess it happened after separately applying the animation to the row.

On a small feature request, I’d like to see more flexible time options for animations that can be set at will, so we can have items in a row or column appear at user defined intervals e.g image A 0.4, image B 0.8, image C 1.2.


#11

Yes, restarted Blocs and selected the local font in the sidebar…


#12

yes, they are.


#13

When you open the page locally (double click the index.html) file do the fonts load correctly?


#14

Not in the side bar. First in the manage font section of preferences.

screenshot_367

Followed by here in project settings.

screenshot_364


#15

no, they don’t.


#16

I just tried that, managed the fonts in the preferences panel at first. But no effect, still the same.


#17

I think its an issue with this specific font, Any chance you could zip up the export and share it here in the forum so I can test it out at my end?


#18

Yes, of course:


Thank you for the great support!


#19

Leave it with me, I’ll take a look ASAP.


#20

I’ve just uploaded that page again using the latest beta and it looks correct, however I’m rather confused that Safari is now using ttf and svg, rather than woff or woff2 that are both available on the server.

It’s the same story in Firefox and only font awesome appears as woff2.

screenshot_368

In b5 it made use of woff and gave a 404 error because it wasn’t seeing woff2 until I added it manually.