Blocs 2.6.0 Beta Build 6


#41

Would it help if I send you the project file?


#42

Not right now, but if you find the steps to reproduce those would be handy.


#43

It was really perplexing in my case. I was working on an about page and somehow all the contents ended up on the copyright page, wiping everything that was there with no indication anything had happened at the time. Since then I’ve found myself regularly checking all pages before it’s too late in case something similar has happened.


#44

Yeah it’s a tricky one to track down I’ve been investigating it for a while now with not many breakthroughs. I’ll keep digging!


#45

Just a thought, but I had been duplicating rows on the about page to maintain equal spacing without having to think too much and then just changing text as required. I don’t know if that gives you any clues. If I remember correctly it was pretty much all in a single bloc.


#46

I’m having a problem where the Classes window is behaving strangely in some instances. Yesterday I tried adding a custom class I had created myself and it showed up in the Classes window but simply had no effect until I restarted Blocs and tried again.


#47

Unfortunately I can’t change the all fonts. Just partially. I’m using the latest beta.
A long time ago, I selected the Lato:400 Google font.
Now I would like to change to local webfont.

When I go to “Project settings” and select the “T” icon, select “Obeject: All” and change the typeface and press “Done”
Save the project, exit. Open Blocs (beta 2.6.0 - build 6) again, open my latest project file.
When I check the project settings, the default font is Lato:400.

After I changed the each item individually. It mostly works.
But the “Paragrap” item later on Lato:400. Unfortunately all item is: Lato:400.

I removed the Lato:400 from the font list (Preferences / Manage Fonts).
Exit, and run again.
After that the default typeface is Lato:400 (Google webfont). :frowning:

I can’t completely replace the google font to local webfont. :frowning:

project_settings


#48

@Ben Perhaps I have misunderstood this but have you added the web fonts first in preferences under Manage Fonts?

From there you need to import a folder with the relevant web fonts before restarting. Looking at your list I cannot see any installed web fonts, which have a different identifier without the Google symbol.

screenshot_377

screenshot_382


#49

@Flashman Thanks, but this is not my problem.
I can install webfont and working. But “Paragraph” can’t change another font.
Always use the Lato:400.


#50

That sounds like a definite bug then, though it’s not something I’m seeing here. I often find that the most successful means of troubleshooting problems like this is to restart Blocs and quite often these problems go away when tried following the restart.


#51

Bug. As I wrote. I’ve restarted many times.
I made a video, you can see here: Lato


#52

Try setting the font via the class manager. Open class manager and look for the p class.

Set the weight to normal or 400 then the typeface.


#53

@Norm Thank you. This has fixed my problem now. :slight_smile:

  • Could you fix the “All Object” typeface change problem?
  • How can I find the list of classes?

#54

In Blocs - also in this beta build I cannot import local web fonts !!!
Blocs doesn’t recognize fonts - no .ttf - nothing…


#55

Read the docs mentioned at the top of the page, you don’t import individual files.


#56

the next release will order WOFF and WOFF2 at the top of the @font-face css rule making them the default choice. Fonts will need to be uninstalled and reinstalled in order for the correct ordering to take place on export, im hoping to have this version out later today.


#57

@Norm I have changed the all fonts to local fonts (Helvetica). After “Save” and “Exit”. I removed the full Lato family (Google fonts) through Blocs/Preferences/Font Manager. After “Save” and “Exit”. After “Open” the project again and “Export”.
After export, the code continue to contain the Lato family (Google Font). :frowning:

One more thing.
After editing p class. The font name always displaying for me Helvetica.
In this case the change will take place, but always showing the Helvetica. Not what I last chose.


#58

Could you send me your project file please.


#59

@Norm Off course. I sent it.
TIA


#60

@Norm Something went wrong. I got an error message:

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

support@blocsapp.com
host mail.blocsapp.com [72.10.35.42]
SMTP error from remote mail server after RCPT TO:support@blocsapp.com:
550 sorry, no mailbox here by that name. (#5.7.17)
Reporting-MTA: dns; evo02.tarhely.com

Action: failed
Final-Recipient: rfc822;support@blocsapp.com
Status: 5.0.0
Remote-MTA: dns; mail.blocsapp.com
Diagnostic-Code: smtp; 550 sorry, no mailbox here by that name. (#5.7.17)