Blocs 3.1 Beta Build 2

Here is 3.1 build 2 with lots of initial fixes.


This goes to the first build @Norm

Update - fixed

I get the latest build. Did you take care to hard reload the page??

1 Like

Most things seem to be fixed. Mail, clean url page links and previews all appear correct. I’m still seeing that favicon error linked to individual pages when I check with scrutiny, which is delivering 404 errors.

@Norm I spoke too soon. That preview issue is back where every page shows the home page.

1 Like

Ok I’ll take a look. Favicon should be fixed. You tried hard reload on pages?

With this build I can’t save changes… just gets stuck at the “Blocs is working, this may take a few moments” screen… filing bug report now


and on the third try, and after a “project export”, it started working… weird… not sure why it wouldn’t “save” and then export the first two times…

The preview issue seems to have gone away now. I’ve uploaded a half dozen changes now and refreshed the site many times.

For the favicon, scrutiny is showing I have 8 bad links on the site and that is effectively every page, other than the home. In every case it’s the favicon with something like or

Interesting I’ll keep an eye out for that. Is this a pulse cms project?

Cool I know what it is! .ico file format I’ll add support for that in the next build.

The build1 thread was locked about the same time I tried to submit my post there, hence my post here. I just filed the following bug report and would suggest that others tried it to see if you have the same problem:

I have confirmed this crash in version 3.0-build20 and in 3.1-build1. It doesn’t always happen though. Last night, it happened 3 times, then stopped and refused to crash no matter how many times I tried the same thing, but then today, after having put my iMac to sleep all last night, I got the crash the first time I tried it again.


  1. New document

  2. Add Gallery bloc “Gallery Images with Description”

  3. In the left sidebar, expand “Bloc #bloc-1” then expand “Container” and then expand the 2nd “Row.”

  4. Note there are 4 columns listed under that row. Click and grab the lowest Column and move it to just above the uppermost Column.

  5. You will now see a blue placeholder line where you released the mouse button. In a few seconds you will see the spinning beachball. Some seconds later, Blocs will crash. Here’s a screenshot:

I just tested in build2, and although I cannot get a crash (unsurprising because it doesn’t always crash), moving Columns doesn’t work as expected. Specifically, I can move the 3 lower columns but when I try to move the uppermost one named “Column” it doesn’t move. There’s also the oddball issue of Blocs allowing you to move a column without it being the selected column. When you first click and select the column you want to move and then move it, it usually gets moved. But if you have another column selected and then try to move a non-selected column, Blocs seems to allow it and sometimes it works but other times not. So there is some fiddly bugs here.

1 Like

It would also be great to have a new feature whereby one could add any web font, even fonts we have created ourselves, as per this thread.

1 Like

Hey JDW nice to see you back and helping to test :+1:

I’ll take a look at this today, I’m hoping to have another build out today with more patches.


I thought the .ico was always supported. I just opened the same project in B2 and found a message saying the favicon was missing. This has never appeared before.


Sure enough in project settings it had also disappeared for some reason, though it was there previously and I’ve now added it again.


I think I’ll wait for B3 and then try uploading again to see if this bad link error goes away.


Yes it is a PulseCMS Project.

1 Like