Blocs 3.1 Beta Build 4


#1

Here is 3.1 beta build 4, patches a few outstanding issues form build 3.

Have a great weekend everyone!

Download Blocs 3.1 beta build 4.


#2

I still get the same easily repeatable crash in Build 4 as I have in previous builds when moving columns in the left sidebar. Below is another crash log. And here’s the video I sent to you previously.

Blocs3.1-Build4_CrashLog.txt.zip (23.0 KB)

To confirm it’s not something unique to me alone in this world, I opened a Guest User (to ensure squeaky clean prefs, etc.) and I ran 3.1-Build4 in Trial mode. I did exactly what you see in my video and got a crash. I would therefore encourage my fellow beta testers to try the same thing and see if you too get a crash. Thanks.


#3

Yes folks give this a try, let me know who can replicate it.


#4

I tried exactly the same as JDW. No crash.
Maybe it has something to do with the OS.
I’m on 10.14.3 BETA 4.


#5

Same here, I have tried to follow the video many times, but no crash.
At the same time, I do notice quite often that moving elements in Layer Navigator is not always smooth.


#6

Tested this myself. New project, opened into full screen, loaded the same gallery, moved the same bric and it was fine, continued moving brics around for around for another 2 minutes with no issues.


#7

hey @Norm i got this bug:


#8

Are you referring to the black scroll bar track?


#9

I cant replicate it either.


#10

tried to replicate but no crash


#11

But I remember in earlier Versions of Blocs 3 (can’t remember which one) this happened to me too.


#12

Why does font awesome have that dot, which isn’t present for the others? Also wondering when font awesome will be updated. It’s now on version 5.6.3.


#13

https://dribbble.com/shots/5880086-Blocs-Icon-Manager-Refresh

The little blue dot indicates the icon set that the currently selected icon is from and the blue selection bar indicates the currently selected set that is being browsed.


#14

It would be useful if there was a means to identify the collection and icon in use from the side panel, even if only as a tool tip on hover.


#15

OK I’ve just found a major glitch here with this latest beta struggling to add structure blocs.


#16

Hi @Flashman

Not a glitch at least for me. The issue is just that the blocs you are trying to select are a little bit outside of the window (overlay on the top) if you scroll down just a little you will be able to select them. This used to happen to me all the time and now I have selected more rows in the window to avoid the issue.

MDS


#17

I wasn’t trying to add brics. This was just trying to add a new structure bloc and it wasn’t working for the first 5 or 6 options. After restarting Blocs it worked again as usual, but I’ve had this happen a couple times in Blocs.


#18

Hi @Flashmann

I meant blocs - (just updated my post). On your screencast you can see there is a window overlay on the structure blocs you were trying to select. The top is darker than the blocs below.

MDS


#19

I’ve just tried it now and had no problems even when it was 90% covered by the area above.


#20

Great so it must be a random issue then.

MDS