Blocs 3.1 Beta Build 4


#21

yeah it’s been there since day one, however its so random I still haven’t been able to track it down. It may actually be a bug with the NSCollectionView, it’s not uncommon for the apple appkit elements to have bugs too.


#22

No, on the left side the page is cut off and on the right side there is a white border.


#23

Am I right in thinking a change has been made to the implementation of lazyloading?


#24

That’s reassuring. Thanks. But did you also try it in 3.1 build-4, in accordance with my video instructions?

It makes no sense that I get it rather consistently, even in a squeaky clean Guest user, when no one else gets the same crash. Then again, who else here has a late 2015 5K 27" iMac running High Sierra? Maybe it’s machine and/or OS specific?


#25

I started my Mac Mini (Late 2014, 2.6 Ghz, 8GB) and LG Wide screen from an external HD with 10.13.6.
Followed your instructions with Blocs 3.1.Beta 4.
No issues.
Sorry man.


#26

I just followed this step by step and even tried holding it in place for several seconds as you did to see if it would provoke a crash, but nothing. This is on High Sierra 10.13.6 with a Mid 2010 Mac Pro. If I have time later on I’ll try it on another Mac that is still running El Capitan.


#27

Looks like a custom class is causing that. Do you get it on export, what does the inspector (preview mode, right click > inspect) show as being the cause of the white space ?


#28

Only the asset urls that are used are now adjusted when clean URL export is used. Why do you ask?


#29

I ran a test last night and exported a site to a test domain with lazyload enabled, then I created a sitemap, which listed all the images, including alt tags. That has never happened before, since it typically just lists the lazyload graphic and stops there.

I assumed you had changed the implementation method for lazyload to get around that problem, but if not, then perhaps clean urls make this possible or maybe Scrutiny has found a way around it. I had a discussion with the developer about this some time ago, but ultimately it needs to work in a way that Google can still index the images and up to now that hasn’t worked when lazyload is enabled. This also applies to pdf files and videos.


#30

I am using web fonts on the server, partly because I prefer it, but also to comply with GDPR. I just took a look at a site and noticed a mention of Nunito via Google fonts, so I dug deeper and there is a CSS stylesheet for fonts.googleapis.com that links to Google. That doesn’t seem right.

screenshot_1087


#31

That’s not a blocs file. Have you checked your pages for an attachment?


#32

Just checked now and there are none. I first picked this up by running a speed test at Pingdom.


#33

Can you not export the project and check the CSS directly after an export?


#34

Good thought. I’ve just checked and it’s not there, which begs the question where is this coming from? The site is 100% Blocs.


#35

Are you able to remove all files from the server and re-upload the project again?


#36

Yes, I’ll have a go now.


#37

It’s no longer showing up on the server in the CSS folder, yet still appearing when I check with the web developer and I’ve cleared the cache a dozen times.

EDIT: Just run another test and it’s still showing up with Pingdom as well.


#38

Hi @Flashman

What if you perform a search for Nunito on style.css ? The result would give which class has Nunito as a font reference.

MDS


#39

It seems to be linked to the title:

.title{
text-transform:uppercase;
text-decoration:none;
line-height:45px;
font-family:“Nunito”;
font-weight:700;
color:#797979!important;

Also appearing for the bloc colour:

}
.bloc-color-h3{
font-family: Nunito;
}


#40

Now if you go back into Blocs in the class manager for instance do you have a class named title ? The title would be in a medium grey color as well.

MDS