Blocs 3.2 Beta Build 3


#41

I think English is the default. Did you try another Language to see if that works?


#42

You could add the modal to the global area then it’ll be included on every page.


#43

I just tried setting it to Cornish for a laugh and it added <!doctype html><html lang="en"><head> right at the start, but surely it should do this for English as well, even if it is the default. Cornish should arguably be set to Cornish, otherwise why include it?

EDIT: Something wrong here @Norm. I just set it to Esperanto and it still exported the page with the English language code. Curiously it doesn’t prompt you to save the project after changing language.

Further update. After trying different language options I’ve found it now includes English regardless of which language was chosen. Before playing with the language setting in project settings no language data was being added.


#44

Very good idea, I was hoping to achive this as well, but according to @Norm that each modal should have it´s own ID it seems to work pretty easy using this ID.
Or am I mistaken?


#45

I tired that but at least on this project (originally created with Blocs 2 then migrated blocs 3) did not work so well. I will try on a clean project. It does not see the modal in global header. There is no selection when I try to link the button to toggle the modal…

24%20PM

Update: Tried it on a clean (new) using B3 project and same results…
Thanks


#46

I stopped migrating my sites. It does work with some modifications but you’re really better off just recreating it in Blocs 3.

With migrated sites you really loose some of the best features of version 3.

Casey


#47

I have been seeing a lot of problems with this BETA release when I go to save some changes (normally something to do with classes) and the dialog comes up saying Blocs is working with a progress bar, proceeds most of the way through the progress and then just hangs. Only way out is to do a force quit and any changes that were made are lost.

This is the same problem I saw for awhile in BETA 1, then it went away in BETA 2 but now it appears to be back, at least for me. A little worrying!

I have had it happen four times today in succession, so I have gone back to the RELEASE version.


#48

The language doesn’t set on current pages, only new ones. So if you change it, it doesn’t change all pages as that would prevent you having multi language sites. It’s just the default setting for new pages :+1:

It’s actually all covered in the docs, defo worth a read.


#49

Try the footer the header may not work.


#50

That makes sense, but I had it set to English as well on individual pages. It wasn’t showing up in the source code at all on the home page until I toggled the main project setting language. I didn’t check the other pages, however this may be a glitch carried over from the recent change with language in the project settings. I had left it as it was.


#51

Oh really that’s not good. Thankfully there are no other reports of this so it’s likely project related.

In order for me to fix I’d need the project and some rough steps to replicate the issue.

I’m hoping to have build 4 out tomorrow with more fixes, hopefully this one included if you provide the materials I mentioned.


#52

That worked great!

Thanks again!


#53

How do you want me to send you the project?


#54

I just spent the last hour trying to get it to fail again using some of the same steps that I use this morning and of course now it no longer gets these crashes. I do not like it when this type of thing happens, grrr!

Maybe there was something bad in the project as I did go back and work on it with the release version. I guess I must have inadvertently elminated whatever was causing the BETA to hang. Sorry1


#55

Perhaps one of the biggest issues I see in Blocs currently pertains to Scroll FX. As we see on Apple’s website, the proper use of Fade is critically important not only for beauty but also to keep the viewer’s eyes focused on the content being scrolled to. The problem I’ve been seeing in my Blocs sites pertains to when Fade In and Fade Out kick in. Many times, especially when previewing in XS mode, I will scroll part way into my text, blowing past an entire paragraph, before Fade In kicks in! Eldar tried to address this by a hack involving setting Padding to 500px and Margin to -500px, but that creates a variety of new problems. For those of you who have not see it, you may wish to read through the discussion here:

I’d love to see a more professional solution to this problem in Blocs. And truly, if Apple can make their website work properly with regard to Fade, I don’t see why Blocs can’t do the same.

Thanks,

James W.


#56

You can do anything if you hand code (which Apple will do). Creating a solution that doesn’t require coding that fits an inifinite set of scenarios is x1 zillion more challenging and complex.

Don’t forget there are 3rd party JS based frameworks for this you can integrate with Blocs too.


#57

What location are you saving too? Sounds like the save drive / location may be the issue.


#58

I just saving to a partition on my MacBook Pro 2018, I have not had any problems with this partition and use it all the time for the RW websites that I work on. SO I’m having a hard time seeing how it might be a problem with the drive.

Today was an extremely frustrating day for me with Blocs, because not only did I lose some work when this happened in the BETA. I then went back to working in the release version and despite saving frequently while working on a project, I ended up in the exact same position where it froze the same way as the BETA. But what really blew me away was that EVERYTHING was lost in the project. When I re-opened the project none of the previous saves had been saved to the project, it was essential back at the starting point that it was at when initially went back to working on it. Really frustrating!

Especially as I had been working all day trying to figure out how to style a navbar and had finally arrived at a workable solution, and then bang it was all gone.

Tomorrow when I recover I’m going to see if I can retrieve one of the interim saves from my TimeMachine backups.

So I have no idea why the problem showed up in the release version, BTW, this is not the first time it has happened in the release version as well.


#59

I’m sorry you experienced this. It’s super rare with Blocs and sounds very likely that the cause is either system or project specific.

Are you using any custom Brics or code widgets in your project?

It sounds like it may be somthing in the app is causing a crash.

Alternatively it could be a drive issue. Regardless of whether RW saves fine to that drive, all apps are different so let’s also assume it could be related to that too.

This has my full attention now so let’s try to find out what the cause is. I’ll DM you to explore this issue further.


#60

First of all, I really like Blocs and I think you are doing a great job, @Norm. I think that goes without saying, but I wanted to say it anyway so no one things I am here merely to speak negativity perpetually. Indeed, when I bug test, I find and report every little thing, and in the course of my testing I find other things like Fade issues.

Here’s the problem with using a code-hack to fix Fade. Fade is currently a staple feature of Blocs, sitting in the right side bar. It’s an in-your-face feature, right there for anyone to use. Naturally, Blocs users will use it. Now when we consider that most of us who use Fade (again, a staple feature of Blocs) find that it kicks in at the wrong time, it is only logic to do one of 2 things to resolve that:

  1. Fix the problem such that Fade begins more quickly so you don’t need to scroll down so much for it to kick in, or
  2. Remove Fade In and Fade Out entirely from Blocs, forcing users to resort to code to make it work properly.

I prefer solution #1. :slight_smile:

Seriously, Fade In & Fade Out are a major part of good web design these days, and the present implementation in Blocs is not ideal because you have to scroll down too much before fade begins. It’s not just me who thinks so. People who buy templates from @Eldar came to him about the problem, asking that he try to resolve it, which is why he resorted to that padding/margin hack which in my testing is very quirky. Surely there must be a way to tweak the current settings in Blocs to make Fade begin more quickly as you scroll down the page, right?