Blocs 3.2 Beta Build 3


#101

@sandy in the Chrome definitions you have Hardware Acceleration turned on or off?


#102

@Pealco it was turned ON, and i turned it OFF and restarted, animation is still running ok in chrome


#103

@sandy ok so in chrome
do fn+F12
Then fn+F1 and in the Preferences Settings go to the Title Debugger and Disable JavaScript and try both situation, and I think you will have the same situation then JDW


#104

I test with this site: https://daneden.github.io/animate.css/
If i disable javascript in Chrome, the animation is not working anymore turm it on again, its working


#105

OK, I will put here somethings that all can try:

I found this things in different forums, and developer pages…

Fix.1 - Some (High Sierra versions) in System Preferences -> general can try disable “Hardware/Software Accelaration” then restart Mac and try.

Fix.2 - Chrome - Fn+F12 -> Fn+F1 and check all settings like DOM - JS - etc.

Fix.3 - Chrome - Fn+F12 and while the Dev box is open go to the refresh icon - Right Click - and choose the 3rd option “Empty Cache and Hard Reload” because 2nd option “Hard Reload” doesn’t empty the cache.

Fix.4 - Chrome - Chrome Preferences - Show Advanced Settings - Select the “Use hardware acceleration when available” option in the System portion of the menu

Fix. 5 - Chrome - Chrome Preferences - Show Advances Settings - In Private and Security - Content Preferences/Definitions (translated from Portuguese) - Then Go to Javascript and check if is turned On and if any site is Blocked

Fix. 6 - Chrome - Type “about:flags” (without quotation marks) into Google Chrome’s address bar, and then press “Enter.” - Scroll down to the “GPU compositing on all pages” option, and then select “Enable” from the drop-down menu. - Scroll down to the “GPU accelerated canvas 2D” option, and then click the “Enable” option. - Close and reopen Google Chrome to save your changes

Fix. 7 - Safari - Safari Preferences - Security Tab and see if you have JavaScript Enabled

Fix. 8 - Safari - Safari Preferences - Advanced Tab - Enable: “Show Develop menu in menu bar” and then try different “Agent Users”.

If I found something else I let you all know…


#106

wow this is super detailed and helpful

Thanks :pray:


#107

We are making in MP with @sandy some improvements… will let you know if we find a solution, we already found a way to make it work but … we tell you later… :stuck_out_tongue_winking_eye:


#108

Well… @sandy tries one thing and it works. He creates a new account/user and in that new user everything was working, animations in safari, chrome, so we found that is not a blocs export issue, or a code issue, but a local issue, with something that is blocking the contents.
Could be caused by any extension that you have or had and leave some “trash” behind. Like Adblock, Pop up cleaner, Pop Up Blocker, etc. etc.
And it could be plug-ins too. Or some extension on plugin that is incompatible with the css code.
It could be too a Antivirus, and in that case normally in all antivirus, you can customize his interaction with Safari or css/javascript/JS.

I had send the following steps to clear Safari. and you can try as well @JDW, both situations, the solution that @sandy found, to make sure is a local issue. And the following one as well:

Step 1: Clear Safari history

Tip: If you’re looking for an easy, two-clicks way, you can use CleanMyMac X to delete data like cookies, history, saved passwords, and auto-fill information.

If you want to clear the history manually, follow the steps:

  1. Launch Safari and click on the Safari menu.
  2. Choose Clear History…
  3. Click the menu next to clear and choose a time period — if you want to completely reset Safari, choose all history.
  4. Press Clear History.

Step 2: Clear Safari cache

  1. With Safari open, click the Safari menu.
  2. Choose Preferences.
  3. Click the Advanced tab.
  4. At the bottom of the window, you should see a checkbox labelled Show Develop menu in menu bar, check it.
  5. Click on the Develop menu and choose Empty caches.

Step 3: Remove Safari extensions

Extensions are third-party add-ons that provide additional functionality to Safari, such as saving web pages to Evernote or Pocket, or downloading videos from streaming sites. However, they can also cause problems, particularly if you let them get out of date or the developer stops updating them, so here’s how to remove them.

  1. In Safari, click on the Safari menu and choose Preferences.
  2. Click on the Extensions tab.
  3. In the window that opens, you’ll see a list of installed extensions. To completely reset Safari, click on each extension in turn and press Uninstall.

Step 4: Switch off plug-ins

  1. In Safari, click on the menu and choose Preferences.
  2. Click on the Security tab.
  3. Remove the checkmark from the Allow Plug-ins checkbox.

Step 5: Delete plug-ins

The above steps allow you to switch Safari plug-ins on and off and to control how they behave with specific websites. To delete them completely, however, you’ll need to manually move them to the Trash. MacOS stores plug-ins in two places, your user Library folder (~/Library) and your Mac’s main system Library folder (/Library). In both cases, plug-ins are stored in a folder called ‘Internet Plug-ins.’

If you think you might want to use the plug-ins again at later date, you can move them to another folder (maybe create one called ‘Disabled plug-ins’) and move them back when you need them. However, given that it’s very important to keep plug-ins up to date, you’d be better off deleting them and then reinstalling them from the developer’s website if you need them again.

  1. In the Finder, click on the Go menu and choose Library. If you can’t see it, try holding down the Alt key when you click; or in the Go menu, select Go to folder and type: ‘~/Library’
  2. Click on the Internet Plug-ins folder in Library.
  3. Drag the plug-ins you want to delete to the Trash.
  4. Click on the Go menu in the Finder again and choose Computer.
  5. Click on the name of your Mac and select the Library folder; or Click the Go menu, choose Go to folder, and type: ‘/Library’ (note, there’s no ‘~’ this time).
  6. Repeat steps 2 and 3 above.

you can reach to this folders easily by in the Finder menu go to “Go” then for the /Library level 1 go to “Go to Folder” and type "/Library"
To go to level 2 in the Finder menu go to “Go” and then press the Option key in the keyboard and it will apear a hidden Library…

And you can delete also the files inside the following folders inside both Libraries:

  • Input Methods
  • InputManagers
  • ScriptingAdditions

Or you can use the following way:

Reset applications the easy way

There is an easier way to clean up Safari, particularly if you want to reset other browsers, like Chrome or Firefox, as well as Safari. CleanMyMac’s Privacy tool allows you to quickly view each browser you have installed and, by ticking a box, delete data such as cookies, history, saved passwords, and auto-fill information.

In addition, the Extensions tool makes it very easy to delete extensions from both Safari and Chrome, just by clicking the name of the browser, checking a box next to the extensions you want to remove and pressing the Remove button. It couldn’t be easier! You can download CleanMyMac X and try it out free here.

Also, CleanMyMac can also reset applications, reverting them to their original state. To use it, launch CleanMyMac and click on the Uninstaller tool. Use the search box to find the app you want to reset and click on it. Now, click on a small arrow next to the app logo. Click the Application Reset button.

As you can see, it’s not difficult to reset Safari and return it to its original state. And thanks to iCloud Keychain and Contacts, doing so doesn’t mean that your saved logins or autofill data is gone for good. It is a significant step, however, and you should think carefully before you proceed.

Then you can go to this site and check if Javascript is working: https://www.whatismybrowser.com/detect/is-javascript-enabled


#109

You haven’t seen anything yet, look at his real detailed post. @Pealco wants @Eldar job. :grinning:
I think you should hire both of them.


#110

@KBConcepts no way… @Eldar do a lot of things that I never think of… and I will never … He is very, very good in his job, and a master in teaching, with detail…

I prefer to help in different things… @Norm please help me with Brics …


#111

DM me your problems, I’ll help you once I’m back at the office.


#112

I’m here at the office. I just restarted FireFox in Safe Mode. Same problem. Animations do NOT work.

–James W.


#113

Hello @JDW
And can you try what @sandy had done? create a new user and check if with that new user works?


#114

Unfortunately, no. When I open a Guest User, every character displayed on screen is a ? mark inside a box character! Never seen that before. Since I can’t read anything in that Guest User, I cannot test anything in it. So further testing in a Guest User must be put on hold until I can understand what all the text is garbled in that way. I have no issues in my primary user though.

–James W.


#115

Guest user is limited, if you can try a real user with administration properties. Just to make sure.
When or if you can please.


#116

I restarted my iMac and upon reaching the Desktop I immediately opened a Guest User and this time the fonts displayed normally. I tested the Animation Page in FireFox and Safari and everything worked perfectly. I then exited out of the Guest User, returned to my primary user and tested in FireFox and Safari again, but I still have the same problem.

Whatever problem plagues my 5k iMac is somewhat irrelevant in light of the fact others have the same problem, and so would some of my web visitors. So even if someone comes up with a complex solution to my animation woes in my Primary user, there’s no magic wand I can wave on the entire planet to magically make everyone else plagued with the same problem to suddenly not have that problem. I can only be thankful that effects like Fade In and Fade Out work fine, albeit with timing problems in that you are forced to scroll down too much before Fade kicks in (a problem that hopefully can be addressed by Norm’s coding wizardry).


#117

Already DM you… can you check please?
Thanks


#118

Could it be a flash cookie issue?


closed #119