Blocs 3.2 Beta Build 4


#1

Here is Blocs 3.2 Beta Build 4, this release is focused on fixes with a few extra nuggets here and there.

If you encounter something you think is a bug, please refer to the Blocs docs first just to clarify its not the intended functionality.

Download Blocs 3.2 Beta build 4


Modals
You can now create modals (popups) here is how you make them.

  • Add a modal bric to the page, make sure it has an ID.

  • Select a button, link, icon or image and set its interaction to modal and then find the target modals ID in the second dropdown below the interaction one.

  • Enter preview mode and you will see the modal is hidden and will be shown when you click the trigger you assigned the modal interaction too.

Hiding Sidebars
You can now hide the entire Blocs UI apart from the menu bar at the top. There are various ways to do this,

  • The main menu view > Interface contains options for hide/show them (includes keyboard shortcuts).

  • Right clicking the sidebar tab area at the top of each sidebar gives you options to hide them.

  • Right clicking on the design canvas, under the interface option on the context menu.


#2

@Norm Thanks for all your hard work.

casey


#3

@Norm Re: the lang assigning issue. I tested in beta4 & in a new project w/ project settings > lang set to something else. It applies to added pages, but NOT to the home page. I think project settings should apply to home page automatically. :wink: FYI (for others): If you want to override this for a specific page, then use the page settings to change it.

Thanks, Bill


#4

I’ve not really played with the modal bric before, but this is appearing as an empty space when previewed. The bric has a id modal-41490 by default. I’ve clicked on the button and set the interaction to toggle modal, linking to the same #modal-41490, which is the only option available. Now switch to preview and it’s a blank page.


#5

@Bill that sounds pretty much in line with what I was finding yesterday, but after switching the language option away from English and back again in project settings it seemed to work. I’m guessing this is some sort of cache issue carried over from when the language option was added there, but it could easily catch users out if not aware of it.


#6

The modal is hidden in preview mode and the button reveals it.

The test project is pretty straight forward.


#7

The button is invisible. It’s a blank page.

screencast%202019-03-07%2019-35-58


#8

That’s because the buttons inside the modal.

Try creating a trigger outside the modal :joy:

The project that comes with this release has an example set up :+1:


#9

Ok understood. It was just a bit confusing the first time when the default bric was immediately invisible. I think I’ll create a few custom blocs with variations, so this is quick and easy to add. Some nice options in the side panel.


#10

I been trying to create a PHP login script to protect some pages. I wanted to set a session variable, however it did not set any session data. So, I created a very basic script as below to test and changed a page to php and added the code… This did not work as well.

Is this a blocs issue or I am missing something basic?? The hello did appear ok…

43%20PM


#11

Check your outputted code to make sure it has not been mutated.

No reason why this shouldn’t work.


#12

Any ETA on when the tooltips direction will be fixed? At the moment it will only appear at the top of text, rather than below or at the side.


#13

Hello @Flashman the tooltips are working fine.
Even in the Basic Version.


#14

@Pealco Not for me. If I set a tooltip to appear at the side of the text it always appears above. I am doing this within a list bric, so perhaps that is the issue. I’ll check on that.

I’ve just been speaking with the client on the phone and they’ve asked if there is any way of changing the tooltip colours. The website is for dyslexia and they struggle to read white on black.


#15

@Flashman, I´ve changed the design of tooltpis quiet often and it was dam easy using the subclass “Tooltps Body”


#16

Use a subclass ( tooltip-inner) this is interesting.


#17

Thanks I’ll take a look.


#18

I just go to Class Manager and then on the “Subclass lib” choose “Tooltip Body” and it fill automatically the class name that @norm talk.


#19

@Pealco After my third cup of coffee I worked it out. I had a brain fade there for a while. It still looks bad though when you cannot set the tooltips to go where you would like.

screenshot_1172


#20

Hello @Flashman, I can add tooltips around as they suppose.
image
image
image
image

About the personalization of the tooltip.

To the body you work in the class: .tooltip-inner

To change the color of the arrow, you have to go to the html code and in the header add the following code:

    <style>
.bs-tooltip-auto[x-placement^=bottom] .arrow::before, .bs-tooltip-bottom .arrow::before {
    border-bottom-color: red !important;
}
.bs-tooltip-auto[x-placement^=top] .arrow::before, .bs-tooltip-top .arrow::before {
    border-top-color: red !important;
}
.bs-tooltip-auto[x-placement^=left] .arrow::before, .bs-tooltip-left .arrow::before {
    border-left-color: red !important;
}
.bs-tooltip-auto[x-placement^=right] .arrow::before, .bs-tooltip-right .arrow::before {
    border-right-color: red !important;
}
</style>

Then just change the color.