Blocs 3.2 Beta Build 4


#21

@Pealco I’ve found the cause of the problem. Previously tooltip adjustments used to jump around like crazy in the side panel and it was a bug that was present for a few months until Norm fixed it recently. The only way I was able to make any edits at the time was by placing the text in a span, however this was blocks the direction option. After removing the span it now works.


#22

@Pealco Thanks for the arrow code. I was just thinking, is there anyway to achieve the red arrow just using classes?

Casey


#23

@Norm Still having trouble with PHP sessions, so I took the following steps to test.

  1. Created two test pages with settings on each page set to PHP and code as the two attachments.
  2. Navigated to the two new pages by changing the URL to direct to each page.
    Still did not see any session data
    Then…
  3. Copied the two new test pages renamed them and deleted all the code from Blocs and navigated to these two new test pages.
    The session then worked as expected

23%20AM 13%20AM

It sure looks like something in Blocs is preventing the PHP session. Any ideas, or suggestions on how I can save the login status to check if user has already authenticated.

Thanks for your help!


#24

I’ll take a look :eyes:


#25

Thanks Norm…


#26

Norm, anyway to get this added in next update? Its almost complete but needs someone who knows how to build brics. The bric works just needs a little help
[Add Animated Counter Up SOLVED!]


#27

Hi @Norm, in this Beta Build 4 I have noticed a bug with custom brics.

Now when I make edits to the JS and save, returning to blocs page I can’t seem to add my bric (or any brics including the core ones) back to the page for testing. clicking on a bric in the sidebar or with the “+” icon does nothing I’m forced to restart Blocs. I’m falling back to stable for now.


#28

Thanks for the heads up I’ll fix that.


#29

@Norm @Whittfield I now also have the custom bric problem. I worked fine for me in the beta 4 until I clicked once on “Reset Custom Bric”.


#30

Not sure if this is a bug, but when dealing with local images in a custom bric, they are not shown. Do I need a special call to tell blocs to use the selected images? If I use hosted images, everything works well.


#31

strange I get the opposite :grin:

I can’t seem to get the add button to become active when I put in a url for Hosted, But local has always worked fine.


#32

@Whittfield, I tried to make a custom bric creation explanation video, which was asked several times here in the forum. I you have once some minutes, perhaps you have any idea, what I am missing, or confirming that it works for you?

(Create a Bric - Manual)

Here the bric, where I have the problem with the local images:

Comparison Slider.bex (37.9 KB)


#33

I’ve already reported the following bug to Norm, but I am posting it here too to see if any of you can reproduce it…

Steps to Repeat:

  1. Open my document, which was created in 3.2-build4:
    KIRAMEK Top Page.bloc.zip (20.9 KB)

  2. Open Page Settings.

  3. Note that the Page Name & SEO Title are both “Home.” Type “KIRAMEK” as the Page Name and then click the “Done” button.

  4. Note that the navigation menu items mostly change to “KIRAMEK”. That is the bug!

–James W.


#34

I’d like to mention one related thing that bothers me. I seems like a bug. When I click on any of the List Items inside Nav Container in the left sidebar, the specific List Item I clicked on does not highlight on the page as it should. Does anyone know why, or is this a bug or missing functionality?

Thanks,

James W.


#35

Hi James,

It’s not a bug. In Blocs, when you change the name of the page, it will affect the names of all navigation links, which are linked to this page. I think all of the links you have in navigation are linked to home page, so this is why all of them are changing. If you were using source ‘None’ it would not happen.

At the same time, I think your blocs project was corrupted, because I can’t select the navigation list (so I could change the source to ‘none’.

So, the name changing is normal behavior, but the second thing looks like some issue. Not sure if there is a bug in Blocs which causes it, or you did something by mistake to corrupt the project.

Cheers,
Eldar


#36

Bug or no bug, it’s absolutely horrid behavior, in my opinion. Why? Because I spent considerable time crafting the names of those Navigation menu items via the Menu Manager. It makes no sense to me that changing the Page Name should blast all my hard work in Menu Manager into oblivion. It shouldn’t matter if the “links” are all tied to that same page. They are LINKS to the page which have nothing to do with the page Name. The page name should be separate and distinct from my individual navi menu item names! :frowning: I will admit I intended to later change each menu item to a unique page or link, but why shouldn’t I be allowed to create different menu names that all link to the same place?

As to corruption of that document (e.g., clicking to drop down the menu in Preview shows all items white on a white background), all I did was create a fresh new document in 3.2b4 and immediately proceeded to build that navigation menu. I spent most of my time building the menu names and getting sub menus setup. And that’s why it is infuriating that changing the page name would do such a thing to my hard work!

I also use SoftPress Freeway Pro 7 (to maintain my non-responsive websites). Freeway allows me to create drop-down menus too, but changing the page name in Freeway does not obliterate my menu item names. Freeway also makes it easy for me to change the color of the dropdown, the color of the menu text, hover states, and width of each drop down menu, including the width of nested sub-menus. I’ve yet to get my head around how to accomplish this in Blocs. I spent 2 full hours searching this forum today in vain for good info. A lot of the search results are for Blocs 2.x and examples shown don’t match the UI of Blocs 3. Frustration!

More specifically, I am trying to recreate the menu bar you see on the following website (one of my Freeway 7 sites):

https://kiramek.com

I’d like to do two things:

  1. Figure out how to replicate that exact menubar look-and-feel in Blocs, pretty much identical to how it looks on my non-responsive site (for the sake of training my brain on how to do it),
  2. Then I would like someone savvy in responsive web design to educate me on how I should rework that rather complex menu to be more friendly to the user on a responsive website built in Blocs. It’s okay the way it is for desktop computers. Users can pull down the menu, then pop out a submenu, and even pop out sub-sub menus too. But on a responsive site it would probably be best to avoid the traditional drop-down menu style and instead click on 製品 to open an overlay that could display all the complex submenu info. But again, I’ve not been able to figure out the best way to accomplish that. To explain what I mean by “overlay,” have a look at the following website and click on the “Recipes” menu item, which pops out an overlay and presents the web visitor with a very complex menu, yet without the fiddly nature of multiple nested sub menus:

–James W.


#37

I just created a sitemap using Scrutiny and it highlighted a 404 not found link in the style.css for the preload-spinner.gif, even though I don’t have this enabled in the project settings.


#38

I think when a user has a menu item that links to a page almost 99% of the time if they change the page name they would like the fact all the links in the document pointing to that page updated for them to reflect the new page name.

You don’t need to use Menu Manager to power the navigation list, just set its data feed to none then anything you assign on the canvas will remain and will not be changed by the Menu Manager changes.

You are creating all your links to point to the same page, thats not a logical way to work. Why not create all the pages (empty), then create your navigation and point all the pages to the correct ones. What you are doing now means you need to go back through your navigation menus at a later date and set the correct pages once you add them to the project.


#39

Thats normal, you cant select the internals of a data fed Menu Manager list as the data is controlled from an external source, so any edits inside would make the data source become out of sync with the feed.

Switch off Menu Manager for the navigation (sidebar right) and then you can assign and select these items within.


#40

From my experience this happens when the item you are trying to select is LOCKED, which is the case if the navbar’s items are using the primary menu. When you change the primary menu to “none” they become unlocked. I know you are supposed to be able to select locked items to add classes to them, but I have not been able to make that work. Every time I click on a locked item it jumps to the first unlocked item above where I clicked.

I only figured this out when I scrolled the tree to the left and saw the little lock icons that are normally hidden if the tree has not been resized wide enough.