Blocs 3.2 Beta Build 4


#41

Not sure if its the same thing, but I’ve always had to disable the Preloader (Spinner) in Project Settings to get my Blocs-created pages to display in Safari.

My brain tends to Think Different from 99% of most people a lot of the time, so hearing that isn’t too surprising. :slight_smile: I still think it is unfortunate though because it’s software making an assumption for me that I do not want it to make.

I’m still very much a brain dead bozo when it comes to intelligently using Blocs, so with that in mind… How do I set my navigation bar’s “data feed to none”? Again, here’s my document (which @Eldar said is corrupted), built in 3.2b4:
KIRAMEK Top Page.bloc.zip (20.9 KB)

Where specifically within the right sidebar?
And with what selected in the left sidebar?

BTW, I just had my Navibar selected and in Appearance (with Theme=Dark) Include Logo and Include Navigation were checkmarked. I then unticked “Include Navigation” and poof!, all the text inside my Navibar was zapped into oblivion except for the English word Home! Well, drat! Opening Menu Manager shows all my text is still there, but for whatever reason it is no longer showing in my Navi bar. I guess 99% of people would understand this, but my poor brain does not! :frowning:

Wow. I never noticed those lock icons before because they are always hidden from view, even when I have my Blocs window expanded to fill my entire 5K iMac’s display!

And last but not least…

I see none of you Blocs experts commented on how to recreate that British Chefs menubar pop-down overlay I mentioned at the end of my previous post. :slight_smile: Seriously, I would expect such a menu to be rather common on large sites where you have a lot of links and nested folders. Since there’s no navigation Bric in that form factor, it’s a matter of figuring out how to use Blocs to recreate that. But first things first. I need to first figure out how to set my navigation bar’s “data feed to none” and then determine if that’s going to work for me.

Thanks,

James W.


#42

Well, after about 40 minutes of clicking around, I finally figured out the steps necessary to “set my navigation bar’s data feed to none”:

It is that sequence of steps which appears to have been what Norm meant when he said, “Switch off Menu Manager for the navigation (sidebar right).”

OK, that part is accomplished. And I see the pull down menus pull-down, although I cannot stretch-out or shrink the width of those drop-downs in a nice WYSIWYG visual way but instead would need to add a Class to accomplish that, which I assume would be true if you wanted to add a Shadow effect, alternate background colors for each item in the menu, etc. A fair bit of work to build a complex menu in this way, but I now understand what was suggested to me now. Hmmm.

One observation… After doing this, everything that was LOCKED in the left sidebar before is still locked. And when I click on individual content in my Navibar, I see a blue box with an “A” appear (as expected), but nothing associated with that appears in the Left sidebar (as I would expect to occur). That means that even if we “switch off Menu Manager for Navigation,” we still cannot see our page selections in the Left Sidebar. Why?

–James W.


#43

Aloha James:

Did you expand the list of links in the tree to see if the individual links are locked? The list itself will still be locked but the links should not, at least that is the behavior I’m seeing.

BTW, there is a slightly easier way to set the data source, if you click on the list item in the tree, the inspector with then display the data source allowing you to change the setting. Same result as you discovered just a different way of getting there.


#44

I wish I was sharing that Aloha air with you, Robin! :slight_smile: But Japan smog will need to suffice for now.

Even after changing the Navibar data Source to None, all the links are still LOCKED in the left sidebar! :frowning:

–James W.


#45

James, I think I have commented on the other thread about this British Chefs Navigation.


#46

Specifically, your reply was posted here (thank you!): Multi Row Navigation with one column spanning two rows

I watched your video but haven’t figured out how to accomplish that design magic that yet. I am still fighting Blocs trying to build a traditional menu. Here’s the latest incarnation of my document (same document as before, so it may contain that “corruption” you spoke of, but with menus no longer attached to the Menu Manager):
KIRAMEK Top Page 2.bloc.zip (22.0 KB)

Please open my document and Preview in LG, then click on the 製品 menu to get the drop down. Note how it looks (i.e., no truncation). Then click on MD view and note how my menu gets truncated! Would you know why that is that happening? Corruption in my document? A bug? Or yet another case of me not understanding how to properly use Blocs?

Thanks,

James W.


#47

Fellow Beta testers, how often have you worked in Blocs only to see this:

Strange1

And when that happens and you then Preview, you see this:

Strange2

I’m quite sure this is a bug, not a feature, but I want to see how many of you have seen this. I’ve seen this through many versions of Blocs. I’ve just never reported it until now.

The problem is, I don’t know how to repeat it. It comes and goes.

–James W.


Blocs 3.2 Beta Build 5
#48

You should do. I’ll check in case it’s a bug.

Rather than just clicking around for 40 mins, use the Blocs knowledge base.

I searched for menu manager and in that search it includes details of how to set the data feed for the navigation list element.

https://help.blocsapp.com/knowledge-base/menu-manager/


#49

I have never seen that. Ever.

Could be caused by a 3rd party app interfering with the look of MacOS


#50

You are referring to the little coiled-snake looking thingy I posted screenshots of just now. Well, that is why I posted such here, to see if anyone else has seen it. I’ve never seen anything like it in any other app, so it is very odd I only see it in Blocs.

–James W.


#51

Yes, It looks like a highlight state on the icon. It’ll be interesting to see if any others see this.


#52

I always disable the preloader, but actually because I have had similar problems with Chrome not loading. This 404 error has never shown up previously.


#53

Please open my document in 3.2b4:

KIRAMEK Top Page 2.bloc.zip (22.0 KB)

Preview in LG, then click on the 製品 menu to get the drop down. Note how it looks (i.e., no truncation). Then click on MD view and note how my menu gets truncated.

Would anyone know why that is that happening?
Corruption in my document?
A bug?
Yet another case of me not understanding how to properly use Blocs?

Another question…

I like to click on menus to get them to pull down, because that’s how the UI works in MacOS. But I don’t like being forced to click on menu items that have submenus to get the submenus to appear. In the MacOS UI, I merely mouseover those menu items and the submenus pop out automatically. I would like an easy way to implement that. Also, I am finding the submenus to be sticky. Meaning, if you Preview my document above and click on the 製品 menu and then click on VISION, the submenu pops out, but if you then click outside the menu to close it, then click on 製品 again, both the menu and its submenu appear! The problem is that the submenu should NOT appear in that case.

Thanks,

James W.


#54

Actually Norm, I am seeing this everywhere in Blocs 3.1.2. Never bothered me, so I didn’t mention it before.


#55

:nauseated_face::nauseated_face::nauseated_face::nauseated_face::nauseated_face::nauseated_face::nauseated_face::nauseated_face:

:face_vomiting:

Ok I’ll see what is up. Are you on Mojave?


#56

Yes, I reinstalled the system a while ago, and from day one it was like this. The color is the Accent color we can set in General System Preferences.

For example, I have it set to yellow, so I get the following.

12%20PM


#57

Got this too @Flashman @Norm. Pre loader is unchecked but CSS is asking for it thus creating a broken link.


#58

Any time to take a look at the PHP session issue?


#59

Ive made a few changes to this, let me know if you still see this in build 5 on the start close button and the sidebar tab icons


#60

Thats fixed in build 5.