Blocs 3.2 Beta Build 5


#21

OK. This works on normal navigation bars but not with hero navigation.


#22

I’ll get that fixed up.


#23

I’ll check that, looks like you may have set the logo via project settings. I’m not sure if that is set up to sync with asset manager changes. Could explain this.


#24

To be honest the export settings should also be in project settings. I’ve been meaning to add that, I’ll get that sorted.

As for the built in help search, Blocs already supports this but the export settings are on a sheet so they are not exposed to the help search. I’ll see if I can hook that up some how.


#25

:scream:

Do you have any Brics in you your Brics directory in the app support directory for Blocs?


#26

No, it’s blank as shown in this screenshot:


#27

BTW are you still getting the odd selection on the sidebar tab icons in build 5?


#28

If you are asking me, could you please link to the specific post where we previously discussed that? (I’ve seen more than one “odd” behavior so I need context to know what you are specifically talking about.)

–James W.


#29

This one.


#30

No i don’t when I chose the magnifier the only folder I have is that “arquivo” because before I realize that I don’t have any Bric I install that new one, and when I go there to edit it, I found that I don’t have any.

Well I can install all because I have a copy of all Brics that I purchased and get free in forum and 3’d sites, but I don’t have the core ones. Can you send them please so I install them mannually?

I can’t remember if there are more, but I can make new, and use the templates to achieve 5 or 6 of them. There are more?

But it is very strange, never happened before.


#31

Ah, the little coiled snake problem! :slight_smile: No, I’ve not seen it yet in build-5, but it comes and goes, so please give me another 24 hours of testing to confirm.

Thanks,

James W.


#32

Hopefully this will make it easier to find in future :wink:

(I’ll get build 6 out before end of week)


#33

That makes more sense to have those settings there.


#34

@Norm I noticed a strange behaviour in bv4 and also in bv5 trying something I had never tried before.

The issue is that I could not select the Link inside the List Item inside the Nav Bar. Clicking on the Link would cause the selected item to jump up the tree, instead of selecting Link. See video below.

However, I did manage to select the Link on a different Blocs file without any issue.


#35

It’s the lost data feed. When it’s set you can’t select them.


#36

So, is this a bug? I have had this issue before as well and I ended up recreating the elements.

What did you mean by the following?


#37

Its not a bug, when a list has a data feed you can select the items within it. As they are being controlled by the menu manager. So any edits you make would be lost the second the menu manager is altered.

It could just do with being a little less abrasive and more explanatory which is something that I’ll have addressed soon.


#38

Don’t you have time machine?


#39

Does the active state work in preview mode (in BLOCS or in Safari) as I’m unable to get it to work…

  • Type ‘active’ into active link box
  • Create class called ‘active’
  • Change colour to red or whatever on the class ‘active’

#40

I tried this without luck as well. I wanted to make the active link bold, but it just made all the links bold.