Blocs 3.2 Beta Build 5


#41

Its working fine here.

Use the built in inspector to see why its not being applied. I’ll upload a basic example as I think this is so basic folks are getting confused.


#42

Ok, tried changing the colour but no luck at all. However, just set it too Bold (900) and worked perfect as it should. Could the nav-toggle class be interfering with the colour?


#43

Super basic project.

The active state is red and has bold text. It will only show in preview mode. Take care to look at the class and its values.

test-active-state.bloc.zip (39.7 KB)

If it is not working in project you have running then it could be related to another class overriding it. So then you should try a more custom active state .my-custom-active-state


#44

Sorted, that would explain why it’s not changing colour but bold text works as my nav-toggle is has colours set on it so it probably can’t over ride that.

Will adjust my classes slightly thanks


#45

Im not seeing this. Any chance of an example?


#46

Use the build in inspector in preview more (right click inspect), you can see what class is overriding it.


#47

Norm,
to be honest, I gave up on this feature.
I found out , that I allmost ruined my navigation.
I don’t know why but for some reason the links in the hamburger menu changed size and fonts. Also it is not possible to get rid of the active state in project settings.
When you delete it it comes back next time you open project settings.
Thanks to timemachine I was able to reverse the project.

I’ll sent you the file with no active state and you can try for yourself.
Should I send it via bug report?


#48

To get ride of the active state class just clear the input field in the project settings.

I think there is a lot of confusion regarding the navigation link states and the class states (hover, active)

I uploaded a simple project, take a look at that it should explain how you do this. There is no way it should effect your existing navigations.


#49

But this is exactly what doesn’t work.
When you clear the field and save the setting it is still there when you open project settings again.


#50

Cool I’ll check that!!


#51

@Norm, I haven’t tried all of the changes but wanted to give you two thumbs up for the Modal option. Works like a charm and this is a very popular and thus necessary feature in websites these days. I wonder if this could be utilized in creating custom ‘mega menus’ (so-called). These modal dropdown ‘menus’ could then replace the default dropdown menus if a more robust dropdown menu is preferred. If we can adjust it’s position in relation to the header, it should work. Now that I think of it, this may also work as a mobile dropdown menu. Simply use a button or icon and trigger the modal, which could be desgned as a menu. cool…


#52

Yeah I had considered that too.


#53

@Norm, I utilized a dropdown button in a project I’m currently developing. It serves as a constant menu - even on mobile. It works well. Check it out and let me know what you think…

www.downtoearthgardencenter.com


#54

Hi @Norm, any updates/news regarding the custom Bric sidebar issue?

I was thinking if the sections were collapsible we could squeeze more rows into the existing UI. …just a thought.


#55

I tested your page in Safari, starting at full display width on my 5K iMac, and then I slowly decreased the width. At a certain width, I see text truncation as follows:

–James W.


#57

LOL … no I haven’t.
How can I reinstall ? I already delete blocs and install again, but there is no Brics inside.


#58

Regarding the dialog box below, I still cannot figure out how to cure this problem.

SoftPress Freeway Pro 7 has a dialog box called “Edit Resources” that shows all assets and whether they are missing or not. That dialog gives me a button named “Show” that when clicked will jump me to the location of where that asset is used, missing or not. Furthermore, that dialog in Freeway gives me a button named “Delete” which can obliterate even “Missing” assets.

Not sure if that can be added to Blocs, but it would have benefits. We could see what Assets are missing at a glance, then be given the option to jump to particular assets where they are used in the document, and we can delete them so we don’t get “Missing” dialogs every time we open a particular document.

–James W.


#59

In the same document that I’ve been doing all the build5-testing, I found yet another bit of strangeness, as you see in the following screenshot:

Out of all the Columns on that page, only the one selected has the strange “Width” settings you see in the right sidebar. Note that the infinity symbol ∞ button is not selected in dark gray as it should be, neither is there any number inside the space between the two arrows.

What trigger this (bug?) was me simply adding manual column width via those arrows, but that I decided I wanted to go back to the original setting and so I clicked on the ∞ and the result is what you see in this screenshot.

Any way to fix this? (The site previews normally and without problem. It’s just that oddball strangeness in the right sidebar that concerns me.)

Thanks,

James W.


#60

I really like holding down Shift and dragging the edges of items to alter padding. But whenever I’m in SM or XS mode, it happens all too often that the important information in the little blue box is truncated by the left edge of the page, as shown in the following screenshot:

I really need to see how many pixels I added. Can Blocs be improved so that little blue box displays all the time, no matter what?

Thanks,

James W.


#61

Right click to remove the asset