Blocs 3.3 Beta Build 6


#1

Hey everyone,

Blocs 3.3 is getting close to release now. Build 6 patches up a few other things, it also adds support for cache busting for page and project attachments (including those added for custom Brics).

Navigation toggle menus are no longer linked. Which means you can have multiple navigations on a single page and they will no longer expand at the same time on mobile when the toggle is hit.

If you still want the linked menu effect just duplicate a navigation Bric. If you want to switch it off on older projects replace the navigation Brics with new ones.

Unless something show stopping turns up over the weekend, Blocs 3.3. will ship early next week.

Anyway have a great weekend folks!
:sunglasses:

Download Blocs 3.3 Beta Build 6.


#2

That’s a great news! Thanks !


#3

@Norm The before and after image bric is broken with this beta, not sure which beta it broke, but the original swiper doesn’t move when you move it back and forth a second one appears. The image does change as you move the swiper back and forth.

It works fine in Blocs 3.2.4

Take a look a this screen shot to see what I mean…


#4

It’s working fine here.


#5

Are you using the latest version of the bric?


#6

Yes, 1.0.1… I deleted the bric and added it back and now it is working.


#7

It cost us a little, but it really is to admire the work of @Norm.

Now ideas will shine brighter! :sunny:


#8

@Norm Thank you for always nice updates. ^^


#9

Can someone show how this new change is implemented on video?


#10

@Norm Blocs 3 Build 6 has major issues!
I’m sitting here with my client updating their site. I need to make a highlight a few words and make them a hyperlink, which was a little painful and embarrassing, but goit it done. After Not getting the selector a few times and having to close down Blocs 3 I was able to get that to work. I blamed it on the Beta. Then I need to make the selected “A” into a custom class, just to make the hyperlink bold. I got to type 2 letters in the name of the custom class and Blocs 3 Locks Up! I tried it several times and finally had to apologized to my client.
I just installed Blocs 3.2.2 and had no problem making a custom class.


#11

yes, I’ve encountered this problem…but slightly different, as the span link test does work, but the issue is with color changes to the selected element.

After making a span link within a paragraph bric (colored white in the image), and then trying to change the color of the paragraph color by selecting the paragraph, and choosing a color swatch, the color of the adjacent column gets changed to the color swatch, but not the selected paragraph.

See example one & two, and provided file:

practice.bloc (739.0 KB)


#12

Finally someone who has similar problems. Let’s hear the from our leader @Norm what is being done about it. It’s really frustrating sometimes.


#13

Don’t sit with a client using beta software, is my main advice, beta software is for testing with the intention of finding problems. There is nothing embarrassing about finding problems with a beta, that’s the entire point of having a beta.


#14

All paragraphs within a bloc are assigned a single global swatch. This is by design. Could it be that the text that is not adopting the colour already has a color set via a custom class? This is likely to over rule the global colour.


#15

Okay @Norm some I have a paragraph I go to highlight a phrase. I run my cursor or set the I beam at the first letter to the end. I usually get a choice like making bold, underlining… but I could not get that choice bar to show up. When I finally did making iot a hyperlink I could not give it a Custom Class name. Blocs 3 would not allow me to type in a name. Blocs 3 would simply lock up!
I installed the last regular release, I think it was v3.2, and had little problems.


#16

update: things are working now. I’ll keep my eye on it.

Yes, understood about a bloc default until a override is applied, which makes perfect sense. Not sure why what I posted had occurred, perhaps sloppy experimenting on my part…


#17

What version of MacOS are you running?


#18

Mac Book Pro with OS X El Capitan 10.11.6


#19

There is a persistent bug in Blocs, present in Build 6 too, that causes the little white handles (for freehand padding changes) to NOT appear when I hold down shift. I cannot tell you how to reproduce it because it comes and goes. And in my documents that are only 1 page, I cannot switch to another page (which usually fixes left sidebar issues), and I am forced to relaunch Blocs for the shift key to make the white handles appear again. When I need to make a lot of changes, that results in a hellacious amount of relaunching Blocs. If this bug can be fixed, I will be eternally grateful!

Thanks.


#20

We cannot UNDO a deleted Class in Class Manager. Is this a bug or a “feature”?