Blocs 3.4.9 | 3.4.10 Error! - Viewport Toggle Visibility

Hello @Norm,

Can you please check the error that I found in this late version?

The viewport LG - > visibility toggle is in LG button -> ok.
The viewport MD -> visibility toggle is in LG button -> NOK
The viewport SM -> visibility toggle is in MD button-> NOK
The viewport XS -> visibility toggle is in SM button -> NOK

Can you please check?

Many thanks

As I don’t know if @Norm check here, I report the bug in support page…
If someone can check if have same problem please reply here…

And I have the odd time when eye, LG, med and small all white, Xs dark, and the opposite and never sure which way will work!
Sometimes dark is on, sometimes white is on!

Thanks I’ll check the support tickets and follow this up.

The last few updates have been essential patches so I didn’t beta test them. But beta testing will begin on release again early next week.

1 Like

Just tried it here in 3.4.9 on a simple bloc with a header and visibility worked as expected at all breakpoints. I tried switching on and off at different breakpoints without issue.

1 Like

Viewport Error

VIEWPORT LG -> Change visibility in LG Button. -> OK

Viewport Error MD

VIEWPORT MD -> Change visibility in LG Button. -> NOK

Viewport Error SM

VIEWPORT SM -> Change visibility in MD Button. -> NOK

Viewport Error XS

VIEWPORT XS -> Change visibility in SM Button. -> NOK

There you have some videos explaining the situation…

I can see you have a problem. That’s just not happening here and it’s behaving normally for me. I am on Mojave if that makes any difference.

It could be something with Catalina … thank you for your help. I’m reporting to @Norm, I’ll see if is only a issue with my Blocs or if is a problem for others users… (except you :slight_smile:)

I was actually reluctant to install the upgrade after I read your post and didn’t know it was available until then, however it seems to be fine here.

There have been times when Blocs was really unreliable for me, though this was mainly the case under Blocs 2. I have to say I am not seeing any of the recent issues that some are reporting. At one time I remember nothing was working properly with Blocs, such as custom classes not being set properly and everything improved after reinstalling the OS.

Nope @Pealco, not just your problem. I’ve been having it off and on since January when I started using Blocs - and I was thinking it was just my setup!
Sometimes a restart of the programme fixes it, sometimes not.
Sometimes I can go through the visibility setting for something a good few times and nothing happens, sometimes it works first time, sometimes off is on, and on is off.
I haven’t managed to figure out a common denominator yet.

1 Like

Thank you for your report @TrevReav.

I am expecting a new Mac to arrive on Monday, following a delay due to an error by Apple. That will enable me to check this on Catalina with a clean install.

@Norm this issue remains in 3.4.10…

Can you please check? I can’t disable visibility in tablets as they are fixed to LG viewports.

Yeah I’m still working on it. The release notes details what is fixed regarding issues.

OK, you’r right, I was hopping it was a missing detail…
You had fixed and not mention it in the release notes: :frowning:

Nope, when I find the cause and have a patch I’ll follow up on the support ticket and always mention it in fixes :sunglasses:.

The save issue in the recent release took priority as it was more critical.

I’ll be in touch soon :+1: