Blocs 4.0.4 Beta Build 2

Hey everyone,

Here is Blocs 4.0.4 beta build 2. It contains a bunch of fixes in various areas, and also addresses a few of the crash issues for those using shiny new M1 Macs.

If you are using an M1 Mac and you continue to get crashes with this beta, please let me know what tasks cause the crashes.

Download Blocs 4.0.4 Beta Build 2


Would any logs helps with the crashes, as from what I’ve seen so far it can be literally anything causing a crash.

Will test this build later tonight though!

1 Like

2 of the main triggers for crashes on M1 where coming from the layer tree selection and undo functions. These are now fixed, so Im hopeful you should immediately find it a little more stable.


M1 Mac users have you found this release more stable?

No. I have the same crashes as with Version 4.0.3 :frowning:

ah thats a shame, I’ve heard this release is a lot better from some M1 users.

What do you find crashes the app in particular?

I opened a ticket [#20484]

1 Like

Hi @Norm!

I’ll be testing some of my projects using this beta. So far, working OK on my M1 Mac mini. Will let you know if I run into any problems.

Thanks for creating this beta. :slight_smile:



That didn’t take long. :slight_smile: I was just clicking on different stuff in edit window of my one project and got a crash. I think I clicked on a card object in the edit window or something inside the card and got the crash. I reopened the project and clicked on same cards but could not recreate.

I got a partial screen shot of the crash report and attaching below. If I get another crash, I can copy the full report if you want. I can also create a ticket if you want.

Will continue testing. Hope this helps.


1 Like

Thanks for the feedback from M1 users. More has been patched up ready for tomorrows build 3.

1 Like

Hi @Norm, please fix the little typo in the extension manager when there’s an update as well. :thinking:

If you have CSS filters enabled during hover as a custom class on an image, then add a .stretched-link class to a link inside the same column it disables the CSS filters on the image.

On the image I tried just now the change in filter effect will work in edit mode, but only when the mouse cursor comes in from above. Nothing at all in preview.

EDIT It seems the effect will work, but only when the class is applied to the entire column, including text etc, which may not be what you want.

Odd, a filter issue like that sounds more like a problem somewhere in the CSS structure.