Blocs 4.3.2 Beta Build 2

Hey everyone, here is Blocs 4.3.2 beta build 2. This release contains a few fixes and a nice new feature that stores search queries in the Bloc and Bric Bar (note they are logged when you select an item from a search query, as search is instant in the input bars).

Happy testing!

Download Blocs 4.3.2 Beta Build 2

Don’t forget to hard reload your browser, if the beta doesn’t show!


Hard Refresh Your Web Browser (to Bypass Your Cache)

There are also keyboard shortcuts to perform the equivalent hard refresh. Because there are multiple ways to do the same action, they will be listed below:

  • Chrome, Firefox, or Edge for Windows: Press Ctrl+F5 (If that doesn’t work, try Shift+F5 or Ctrl+Shift+R).
  • Chrome or Firefox for Mac: Press Shift+Command+R.
  • Safari for Mac: There is no simple keyboard shortcut to force a hard refresh. Instead, press Command+Option+E to empty the cache, then hold down Shift and click Reload in the toolbar.
  • Safari for iPhone and iPad: There is no shortcut to force a cache refresh. You’ll have to dig into settings to erase your browser’s cache.

After you perform the hard refresh, you should see the web page go blank, and the reloading process will take longer than usual. That’s because the browser is redownloading all of the data and images on the site.

1 Like

I still see instances where opening a project has somehow lost a hero background image applied via custom class. On some sites I’ve had to add the same images three or four times now.

Are these being loaded from a server?

The one I just tried with this problem was located locally in the resources folder, alongside the project file. I saw the same thing with another site last week that had also been added in the same way. As a test I just checked another that was hosted on the server and that was fine. I think it’s more likely a case of background images loaded via custom class, rather than hero blocs as such.

In a nutshell, I’ll open a project expecting to see the hero image and it’s blank, though everything else is there as expected. I can easily locate and add the images again via the asset manager, but maybe come back a month or two later and find it is gone again.

I think these were all sites that started life under Blocs 3 if that gives you any clues. They haven’t yet been converted to BS5, so that is not the issue.

1 Like

Nice @Norm,

I was having issues with an Orphaned Div on the canvas that was stuck. (not even on the layer tree), and opening the project in this beta resolved it!

This project started in 3, moved to 4 and was recently updated to Bootstrap 5.

1 Like

Hello, I was wondering if the report I sent regarding assets not being exported with v 4.3.1 is encountered by someone else and taken into account in 4.3.2.

As reported, Blocs 4.3.1 don’t export my assets. I have only two images: 1 for a bloc background and 1 logo. Both are displayed in Blocs and Preview but not exported. Reverting to Blocs 4.2.2 solve this. I mention it here because after 2-3 weeks, I tried again to launch v 4.3.1 and same thing happens, no images in folder after export. 4.2.2 still working.

I’ve been seeing this issue in v4.3+ where button interactions no longer show up when a certain button is selected.

1 Like

thanks I’ll take a look at that and see if I can spot the cause.

1 Like

Just adding a remote hosted video to a site and finding it keeps disappearing in edit mode, but available in preview. I’ve found myself continually having to reselect it in the asset manager to see in edit mode.

I am still having frequent issues with 404 errors appearing within the exported CSS code. Previously I thought this might just be a Blocs 3 bug that was carried over, but last night I found it in two new Blocs 4 projects.

In these case there were 404 errors for image files called layers.png, layers-2x.png and marker-icon.png and none of those sound like files I have created myself. They are all referenced in leaflet.css and flagged as not found. The url is in the CSS.

In other cases I have found references to images that were long since deleted months or years ago, yet still appearing in the CSS.

1 Like

@Norm, You must be one busy guy all these issues that are mentioned in this beta. I guess that’s normal because it’s a beta. I really don’t want to do this, but here is a video of some really strange thing happening.
My question is and ,anyone can answer this, How do you delete a block that is so corrupted that when you click on it it goes to another location. I tried everything…removing all the elements and then trying to delete it, but as you can see it doesn’t work.

Because the Blocs software is always being driven forward with new features, support for new versions of Bootstrap, MacOS etc, you will always get bugs.

Most issues in this thread are not show stoppers or wide spread, but expect to see many of them addressed over the coming weeks of testing 4.4.

As for your issue, it looks like your structure is not being read correctly for the later tree. A coming reason for this is pasting in text with random hidden characters or some kind of glitch in the inner workings of a text Bric.

Feel free to DM me the file and I’ll take a look.


Any chance you can send me a copy of the project file?

@Norm, Please check your PM.

1 Like

If I delete a remotely hosted video from the server this fails to be reflected in the asset manager and still appears with the cloud symbol, even if it cannot be added to the project. When I look to delete unused assets it is not included in the list either.

Of course @Norm. I was away this week. Sent to your email. Thanks