Blocs 4.4 Beta Build 8

Hey everyone, here is the 8th beta of Blocs 4.4. This release patches up a bunch of issues new and old.

Still a few more improvements to come before release…


Dark Theming
Blocs 4.4 introduces a range of improvements to aid the workflow of creating a website that supports dark and light theme modes.

The class dark-theme is added to the body tag when a Blocs site is run on a device that is running a dark OS theme.

Within Blocs you can emulate this using the canvas dark site mode option to switch the dark-theme class on and off within Blocs, this is also applied to in-app preview, but not preview in browser (that is depended on your Macs own theme option).

In the Class Manager if you right click a class you can also now opt to create a dark theme version of a class. Any changes made to this will only effect the site when run in dark mode. Notice it’s just a duplicated class with the leading dark-theme class before it.

Thats basically how you target dark theme .dark-theme .yourclass

The video below is a quick example of setting a Bloc background dark for dark mode.

Dark Theme

Missing Font Manager
The Missing Font Manager will be shown if a missing font is detected when opening projects, adding custom Blocs and page templates. At this early stage of testing, it may be triggered without reason so keep an eye out for that.

Localisation :jp:
Kon’nichiwa! Our Japanese speaking users will be happy to hear Blocs now speaks Japanese. You may notice a bad translation, some text cropping or another little interface oddity. Please let me know if you spot something and it’ll be fixed up in no time!

New Wordpress short codes
Some new short codes for Wordpress.

  • %WP_singleCatTitle% = <?php echo single_cat_title();?>
  • %WP_singleCatIdVar% = get_cat_ID(single_term_title("", false))
  • %WP_postCatIdArray% = wp_get_post_categories( get_the_ID(), array( ‘fields’ => ‘ids’ ) )
  • %WP_getPostArchiveLink(PostArchiveNameGoesHere)% = <?php echo get_post_type_archive_link('PostArchiveNameGoesHere'); ?>
  • %WP_categoryURL(categoryGoesNameHere)%) = <?php echo get_category_link(get_cat_ID('categoryGoesNameHere')); ?>

Happy testing folks and have a great weekend! :beers:


Download Blocs 4.4 Beta Build 8

Don’t forget to hard reload your browser, if the beta doesn’t show!


Additional
Im still working on a few other outstanding issues such as missing background images so please sit tight those will be addressed soon.

4 Likes

It’s happened again with this saving issue. It was fine two minutes ago and I’ve been saving manually as I edit text every few minutes. Suddenly the only way I could save the project is by creating a new project file. Would it help if I send you the project file? We haven’t yet established this is definitely iCloud at fault.

Thinking outside the box at the moment, I wonder if this may have been influenced by anti virus settings on my router if this is network related in some way. I say that because a particular anti intrusion setting has caused problems with FTP transfers and also site scans with Scrutiny.

So far this has only happened with a single project but it might be the size at over 100 pages, which is a factor.

On the same project I see some spinning ball for a 3-5 seconds every time I preview the website if I have made edits without saving. Once saved the preview is pretty much instant as usual.

Looking at iStat menu while this happens I can see the GPU barely kicks in. The CPU hits 100% but on a multicore computer that could go to 1200% in theory on this mini.

This is not something I have seen on smaller sites and at the moment there are hardly any graphics, because the text is still being written. I noticed this before much text had even been added and it just seemed to emerge when the site neared 100 pages.

If I click a class inside the classes window the class editor opens as expected. If I then delete that class using the red button from the same class editor popup I cannot help thinking it should disappear from the classes window as the editor is closed, however it remains in place and has to be deleted manually afterwards.

1 Like

If I have a link in Blocs to an external page I can right click in preview mode to reveal “open link in a new window”, but when clicked nothing happens.

It would be nice to fix this, though more usefully I would like the option in edit mode to open a link with a web browser, so I can check pages for reference. If that creates problems perhaps the page note bric could be adapted to include a url option.

1 Like

Beta 8 is not asking for saving when you close the app.

@Bootsie It worked in my case when checked now, but there is definitely some odd behaviour with saving and I’ve had more instances of the problems mentioned above. In addition I have seen a return of the old bug where just clicking inside a bric now shows the site has been edited, even when nothing was changed.

Good to know I’m not the only one.

What edits are you making when Blocs is not asking to save on close. Nothing has changed in the code base for Blocs regarding saving but this new beta is compiled with a newer version of Xcode :thinking:

Is this a custom Bric? That behaviour can be triggered by an API call.

Adding blocs and brics, make adjustments etc.

As we speak I tried again and it worked.
So this seems to happen randomly.

1 Like

No just clicking inside a paragraph bric makes it happen.

1 Like

Ok I’ll check that, may be new as I tinkered with undo for writer mode.

Typically! If you spot a pattern to get this to happen again let me know. :+1:

1 Like

Thanks for fixing the .ratio thing @Norm its working great.

I found I have the same issue using .carousel classes.

See the layer tree. I have 1x Div with a nested Div, and it starts handling it like the build in Carousel.

1 Like

Is there an example of using a carousel class for something other than a carousel?

Blocs identifies a carousel with this class.

What I mean is when you’re making your own one using Divs with different content. It starts doing odd things.

The only way around that is just using the Code Widget. But then managing images sucks a little :grinning_face_with_smiling_eyes:

I was just wanting to make something simple without using swiper.js or similar when it was overkill.

1 Like

Ah ok, I’ll see if I can improve that.

1 Like

Hey @Norm

In Bootstrap 5 the class .form-select is missing off the select element. It does have .form-control which isn’t required, so I would say thats the mix up.

The result, no dropdown chevron.

It’s also like that in Blocs 4.3 too.

1 Like

Thanks I’ll check that.

1 Like