Blocs 4.5. Beta Build 3

It’s been an upsetting week for many. We know there are Blocs users who will be directly and indirectly effected by the events in the Ukraine. We had plans to send out the Blocs newsletter mail shot earlier this week, but it just didn’t feel right, so we have put that on hold.

We have a number of fixes for the latest beta version of Blocs, which we want to get out as it effects some users websites, I just didn’t want to post a beta update without first acknowledging the more import issues going on right now.


Here is Blocs V4.5 beta build 3.

Thanks to all who are able to help test this beta build.


Download Blocs 4.5.0 Beta Build 3

Don’t forget to hard reload your browser, if the beta doesn’t show!

20 Likes

7 Likes

Слава Україні! :ukraine:

6 Likes

Героям слава! :ukraine:

6 Likes

Ladies and Gentlemen,
I have a row with 2 columns inside a card-body.
The width of the row shows up different in Blocs 4.5.0-b3 than with Blocs 4.4.2.
See pictures.
The settings are the same and there are no classes applied.

card_settings

@Bootsie

Hi,

you seem to have a class (.bloc-28631-margin-top) being applied on second column.
Maybe check that first?

Right, but this should not matter. The point is that the width should be the same in both Blocs versions.
Anyway, I removed all classes just to make sure and it’s still the same.
I think it’s a bug in 4.5.0-b3 and b2.

Just curious: how do you know, that there’s a class applied?

Hi,

you can see a class applied on the left sidebar alongside the item in question - beginning with the dot.
In your example it is: Spalte .bloc-28631-margin-top.

Also: you see applied classes in editor at right top corner when you select the desired element.

Maxim, sorry 'bout the misunderstanding. You’re help is really appreciated, but I’m with Blocs for a couple of years now and I know about classes. (almost :smiley:)

What I meant is, how could YOU find out that there’s a class unless You’ve been on the website itself?

Hey Bootsie,
die Klasse ist in Deinem Screenshot sichtbar :rofl:

Bluesige Grüße aus Köln :clown_face:Alaaf

OMG.
Too much “Mardi Gras”.

Keep on grooving :notes: :musical_keyboard:
Grüße vom Harpspieler :stuck_out_tongue_winking_eye:

Ditto. :grin:

But back to the problem.
@Jerry, @Malachiman, @Norm any idea?

Can you post / PM the file with the card only? I’ve tried to duplicate your error following the instruction above but it behaves as normal for me.

Done.
Thanks a lot.

Hi @Bootsie. Allow me to answer here. I think there’s a bug in 4.5B3 and @Norm might want to look into this.

When opening 4.4 with the inspector your card looks like this:

When opening in 4.5B3 it looks like this:

A class called .divider-half is added and has its width set to 50% (that’s why its called half :grin:)

To my knowledge this is not a bootstrap class so it needs to come from somewhere. As its not in your file its ( I assume here) Blocs which adds it.

Adding the class .divider-half to the class manager and set the width to 100% gives me different results on different occasions. In one occasion I added the class and when removing it the width did reset itself magically to 100%. :thinking:

A work around would probably using Flex instead of column for now.

Thanks a lot Jerry for diving in to this.
It’s truly magic.
I hope Norm will take a look.

@Norm

I’m experiencing some weird scaling issue in Blocs editing window in the latest beta - it is like the content of the bloc has shrunk (see pic below). It is not Zoom - I tried.

Weirdly enough there are no issues in preview mode and also when I open the project in 4.4.2 there is no such thing…

Any chance you could please sen me a copy of this project?

Hey @Bootsie @Maxim I think this issue is caused by the new dividers. Blocs 4.5 contains a migration function for dividers to move them to the new HTML. However, it looks like its causing some errors when the half divider is used.

Fix coming today.

Please note, the fix will not correct projects saved in Blocs v4.5 beta 3.

But when you open your project in 4.5 beta 4 the error should no longer occur as long as it has not been saved in V4.5 beta 3.