Blocs icon in the Dock disappears

Blocs icon disappears when using the app. After closing it comes back!
Anyone else with this problem?

I have encountered that once. I am running MacOS High Sierra. I have heard others have experienced it too, albeit rarely or only once. No one seems to know what causes it. It’s one of the great mysteries of Blocs! :slight_smile:

Hope Norm has a solution for this
@Norm

The solution is to restart Blocs :grinning:

The icon changes in Blocs v4 at various stages, because of that, this really small icon randomly crops up, I tried to find the cause but have had no success yet.

I’ll keep investing.

2 Likes

I’ve had other apps do this as times. Restart seems to fix it.

You would win a gold star in the mac community if you do. :wink:

It happens to me 100% of the time. I restart my Mac and the App and it’s still the same.

MacBook Pro (13-inch, Intel i7 2020, Four Thunderbolt 3 ports)
Big Sur
Blocs v4.1.1

Have you tried this https://www.alphr.com/fix-missing-dock-icons-mac/?
It seems like a OS issue rather than a app specific problem, although I’ve never run into it (yet)

1 Like

Good Call. I haven’t tried that yet, but my icon doesn’t disappear - it shrinks down to about 20% of normal size while I’m using Blocs, and randomly. I can use Blocs for hours, and it stays as it should, or it can shrink after 2 minutes, 5 minutes, whatever at other times.
Also, it only affects Blocs 4, not V3 or any other apps.