Blocs keeps crashing 3.4.6

Hi, I upgraded to the newest version but now as soon as I open a older porject it crashes straight away. If I start a new project it lasts about 2 mins before crashing. Deleted Blocs and downloaded a new on from the Blocs webite but still the same problem. Downloaded the Bloc beta but again it crashes. Is it just me?

Process: Blocs [6195]
Path: /Applications/
Identifier: com.cazoobi.Blocs-3
Version: 3.4.6 (349)
Code Type: X86-64 (Native)
Parent Process: ??? [1]
Responsible: Blocs [6195]
User ID: 501

Date/Time: 2020-04-19 14:51:53.446 +0100
OS Version: Mac OS X 10.15.1 (19B88)
Report Version: 12
Bridge OS Version: 4.1 (17P1081)

Time Awake Since Boot: 32000 seconds
Time Since Wake: 1000 seconds

System Integrity Protection: enabled

Crashed Thread: 0 Dispatch queue:

Exception Type: EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000


you should open a ticket here:
because it is the more direct and quicker source for your problem to be solved.
I’m sure that @Norm will help you.