Blocs v2.4 Missing Assets Feedback required

Hey everyone,

Im working on a very strange issue that prevents assets that are added to a Blocs project from showing on the design canvas, if the assets are hosted on an external drive.

This effects my iMac but not my newer MBP, so it’s not wide spread. I’m trying to get to the bottom of why its happening so feel free to help out.

Here how you can help:

• Create a new project using Blocs 2.4

• Add an asset to the project that is hosted on a local storage device such as an external HD or USB stick.

• Add this asset to the Blocs design canvas. ie add the image to your website design.

weather it loads or not, please follow up with the following details.

Did the asset load correctly? YES / NO

What is your MacOS version?

What age is your Mac?

I have had one report of a potential fix which makes me think it’s a prefs issue with the problematic Mac but Im still unable to manually fix it by flushing prefs etc.

  1. NO
  2. Mac Os Sierra 10.12.4 (16E195)
  3. MacBook Pro (13-inch, Mid 2012), 16 GB 1600 MHz DDR3

Grazie per il tuo lavoro!


1 Like

If I add the image as the background of the bloc I do not see it either in asset manager or in Blocs, but I view it in browser preview.
If, instead, I add the image to the page I do not see it in the asset manager, even in Blocs and Safari preview.

ok thanks.


If you can reproduce this on the guest account I doubt it’s a prefs issue.

Another thought… if this is only happening with users on Sierra, it maybe due to translocation. If that is the case, running the following in the terminal should fix it:

xattr -d "pathToBlocsApp"

@Norm BTW, are you signing the disk image the betas are delivered on?

I’ve never tried it on a guest account. I’ll do that, thanks!

One report states that they removed Blocs and the beta using MacBooster and then re-installed both and all worked as normal. Its something to do with CORS, the web view thats showing the design canvas is somehow blocking assets from other drives from loading but doesn’t throw an error.

The work around is to run a local server and then load assets via the http:// but before I go down that road I want to make sure its not easily fixed by kicking the Mac up the butt and deleting a few things.

Yes the DMG is being signed. It also effects my iMac prior to the app being embedded in a DMG, so I don’t think it’s anything to do with that part.

Out of interest are you effected by the issue?

  1. NO USB stick
  2. Mac Os Sierra 10.12.4
  3. MacBook Pro (15-inch, Early 2011), 16 GB 1333 MHz DDR3

you cant load images from a USB stick?

only the file name but the image not visible

with 2.3.1 ok with 2.4 no

1 Like

I haven’t been doing any site related work for a while so am not using the beta.

Give it a try if you have time. The more info I collect on it the better.

I just installed it and it is indeed quarantined, which is weird as it seems properly signed. I’ll do a little testing and get back with you later. Is your install of it quarantined as well?

Ah right its getting quarantined at your end too. Do you think that is why it’s blocking the the assets from other drives?

Im not familiar with what limitations this puts in place.

I double checked again today and DMG is defo getting signed from what I can see, although Xcode manages my certs so its very possible an update to Xcode could have effected it. I did try your trick above to de-quarantined the app but it didn’t help.

Anything you can find or uncover here would be greatly appreciated, 2 days of coffee and sleepless nights and still nothing at my end :frowning:

I tested b6 with an HFS+ partitioned Sandisk USB stick… (Same issues with network volumes as well)

1.) No imported graphics are visible in the asset manager (just blank placeholders with names).
2.) no placed graphics are visible in Blocs.
3.) Graphics ARE visible previewing in browser (Chrome and Safari).

The above results were the same with or without the quarantine x-attribute, and on my main user account and the guest account (neither of which have admin permissions).
Permissions on external drive are 664.
13" Macbook Pro early 2011 running SeeError 10.12.4

It would screw up anything referring to relative paths to the application.

BTW I checked the signature on both the app bundle and the DMG and both are signed with a dev cert in your name, so it was surprising to see the quarantine x-attr after installing and running it.

Also logged in to my admin account so I could see console messages (damn you Apple) and spied this immediately after importing assets…

default 06:16:51.652752 -0700 Blocs errors encountered while discovering extensions

Im wondering if this is an MacOS issue as I just created a fart app to test loading a html document that had images embedded from multiple volumes and it would only load the images from the volume the html file was hosted on…

So this is not specific to the Blocs application, even a brand new app with no job but to load a html file wouldn’t load it fully unless all parts were on the same volume. This is either an Xcode balls up or macOS balls up.

on a side note all test on Yosemati and El Cap work just fine.

Maybe another one of Sierra’s “Security” features?

Maybe, I think I’m going to post in the WebKit forum to see if it’s more widespread.

Hi. if this is the correct post. All my image files from the img and vid folder in my project folder. All files in the img folder have gone except for pageload-spinner, placeholder-image-sq, placeholder-image and the video from the vid folder. All assets have been removed or moved after a project export. not moved to another part of the project or my pc? they were there, site was fully uploaded. please check or could you suggest where they might have gone.

7 years old, Barely used.
Sierra 10.12.4
MacBook Pro (13-inch, Mid 2010)
Using Document folder. No external storage used.

thanks, Danny