Blocs v3.2.3 beta build 2

Here you go folks, something for the long weekend.

This build focuses on more bug fixes with the layer tree and other areas.

Have a great long weekend and I’ll see you folks next week.


Blocs 3.2.3 Beta Build 2

7 Likes

first bug is that when you select another brick it keeps on adding heading 1

Confirmed here as well. It’s basically preselected, but you can choose others.

And it’s defo not in drop mode?

It’s basically highlighted by default in drop mode. You can select whatever you like.

1 Like

What happens if you search for a bric?

It goes correctly the one you search for. I just typed in snap and it took me to the snap scroll bric.

I am seeing the same behavior as @Flashman

So if you open the bric bar and click any bric it always adds header 1?

I want to experiment some more, but I hit some strange behaviour earlier with snap scroll bric if I have a bloc on the page with a button set to toggle visibility. Instead of the revealing the hidden text below it was scrolling to the top of the page.

No it adds whatever you choose, but the H1 header is always highlighted when opening the bric bar.

Ah so this is normal now if you hit down arrow key you can navigate with keyboard, hitting return adds selected bric

OK I see that now, but it’s sticking frequently. I had to click the right direction cursor key about four times before it started moving then it went where I wanted up and down etc. At a certain point it stuck on H4 and didn’t want to move in any direction.

I then tried again and the paragraph bric was highlighted, but it wouldn’t move in any direction at all using the arrow keys.

Tried again a few times now. Sometimes it moves freely and quickly. Other times it’s completely blocked.

Ok I’ll check that.

I haven’t officially reported this as a bug using the bug reporter because I wanted to post it here first and gather your thoughts. First, please watch my screencast (no sound) where I clearly show the problem:

(It’s currently 1080p, but eventually you can watch it in full 4K in Chrome or FireFox.)

And here’s my document (an updated version of the one @Norm fixed for me earlier today):

Archive-fixed.zip (4.1 MB)

The problem existed prior to Norm’s fix though, so his fix did not cause it. An older version of my document has the same problem even in the release version of 3.2.2.

Can some of you test my document to see if you can reproduce the same problem? First, export and test in Safari. (Click the search icon in the upper right, type a search term and hit return to get the results page.) Then return to Blocs and change the background color of that same Bloc you see in my video (to anything other than black), then export and test again. If you get a black background too, then I guess it’s a bug, unless one of you can explain why it happens.

Thanks.

Hello @JDW I try your both files (original) and normal, and both work very well, and I could change the colors:

The only thing that I could remember if it is something about the export settings, mines are like this:

2 Likes

Welcome back Pealco.
I’m really, really glad.

4 Likes

+1 here too. Let’s keep it positive.
:woozy_face:

Thank you for testing, @Pealco !

No. My page settings are exactly like what you show in your screenshot. Any other ideas?

You can see exactly what I’m seeing by watching my video. It’s clear I have the problem, but I don’t understand why. @Norm?

In this beta the last saved date is appearing, however the last opened field is blank. This is a project I’ve been working on yesterday and today using this beta. It has been opened and closed several times.