Blocs V4.4 Beta Build 5

Hey everyone, here is the 5th beta of Blocs 4.4. This release adds a few more fixes and improvements.


Dark Theming
Blocs 4.4 introduces a range of improvements to aid the workflow of creating a website that supports dark and light theme modes.

The class dark-theme is added to the body tag when a Blocs site is run on a device that is running a dark OS theme.

Within Blocs you can emulate this using the canvas dark site mode option to switch the dark-theme class on and off within Blocs, this is also applied to in-app preview, but not preview in browser (that is depended on your Macs own theme option).

In the Class Manager if you right click a class you can also now opt to create a dark theme version of a class. Any changes made to this will only effect the site when run in dark mode. Notice it’s just a duplicated class with the leading dark-theme class before it.

Thats basically how you target dark theme .dark-theme .yourclass

The video below is a quick example of setting a Bloc background dark for dark mode.

Dark Theme

Missing Font Manager
The Missing Font Manager will be shown if a missing font is detected when opening projects, adding custom Blocs and page templates. At this early stage of testing, it may be triggered without reason so keep an eye out for that.

Localisation :jp:
Kon’nichiwa! Our Japanese speaking users will be happy to hear Blocs now speaks Japanese. You may notice a bad translation, some text cropping or another little interface oddity. Please let me know if you spot something and it’ll be fixed up in no time!

New Wordpress short codes
Some new short codes for Wordpress.

  • %WP_singleCatTitle% = <?php echo single_cat_title();?>
  • %WP_singleCatIdVar% = get_cat_ID(single_term_title("", false))
  • %WP_postCatIdArray% = wp_get_post_categories( get_the_ID(), array( ‘fields’ => ‘ids’ ) )
  • %WP_getPostArchiveLink(PostArchiveNameGoesHere)% = <?php echo get_post_type_archive_link('PostArchiveNameGoesHere'); ?>
  • %WP_categoryURL(categoryGoesNameHere)%) = <?php echo get_category_link(get_cat_ID('categoryGoesNameHere')); ?>

Happy testing and have a wonderful weekend! :beers:


Download Blocs 4.4 Beta Build 5

Don’t forget to hard reload your browser, if the beta doesn’t show!


Additional
Im still working on a few other outstanding issues such as missing background images so please sit tight those will be addressed soon.

2 Likes

Awesome! Thanks, @Norm. :pray: :partying_face:

2 Likes

Hi Norm,

I brought my MBP into the office today with an external 2TB SSD that has the vastly inferior, 32-bit app-killing version MacOS called “Catalina” on it. I plan to test the newest B5 on that and also on my iMac with its heavenly version of MacOS known as High Sierra. Comparing the two will perhaps help me see what you are seeing. May take a while since download is slow for some reason right now.

Installed on Catalina, but my Blocs 3 codes yield this…

Can’t seem to find any email with a Blocs 4 code. For now, I’ll need to deal with this in Trial mode.


Under Catalina, using B5, I see this…

image

It’s truncated at せ but it should end with ません
That’s the no content message in the left sidebar when you open a new document.


“Search Pages” is still in English for reasons unknown. I translated it in Localazy.

image


Blocs Preferences & Project Settings & Page Settings are all fine under Catalina (no Japanese text truncations) when using Blocs B5. For some reason those dialogs are very narrow on High Sierra. High Sierra is still a much more solid OS (and 32-bit app friendly too!) than Catalina which is why I have zero interest upgrading, but I do see that difference in width now. Besides, I use the English UI anyway, so the Japanese truncations I notice won’t affect me at all. It’s just what I noticed while testing the Japanese UI on High Sierra. From now on I will need to boot from the MBP’s external Catalina drive to test the Japanese UI.

Bric Builder is also fine in terms of having no truncations in Catalina, but there are many English words there which are not translated. Some words like “Position” are translated in Localazy, but many are simply missing from Localazy.

I confirmed the misspelled word “Categorie” is now properly translated into Japanese within Bloc Editor. Thanks!


Within Class Manager, the little “i” tooltip text is still in English in B5 under Catalina…


No truncations in Class Editor now (B5, Catalina), but the English word Orientation is not translated, even though I do have a translation in Localazy…


These two Contextual Menu items are still in English because they are missing from Localazy…


Tooltips like “Create text link” still need translations too (missing from Localazy):

image


And last but not least, there seem to be some improvements to UNDO and Writer Mode. If you edit text in Writer Mode and then click the close box, and then after that do a single Undo, nothing happens. I still takes 2 UNDO operations to undo and restore the text to its pre-edited state for some reason. Even so, the bigger problem of multiple-undos having previously not worked as expected now seems fixed.

And that covers everything I mentioned before in the B4 discussion.

Keep up the great work, Norm!

1 Like

Hi, @Norm. I notice something odd. The highlighted Bloc does not match the selected breakpoint. The MD and SM breakpoint Bloc is highlighted when having XS activated on the canvas. :thinking:
Kapture 2021-09-06 at 14.02.39

Very interesting find.

Hi, @Norm. Just ran into another oddity. When adding an SVG icon to a class it inherits all other classes in the Blocs file.

Kapture 2021-09-07 at 06.18.03

1 Like

How about this one I try to open my project and Blocs immediately closes! ;-(
Okay, let’s assume my file got corrupted, is there anything that can be done beside re-building the entire site?
Already sent a crash report, so no need to suggest that.

1 Like

@KBConcepts to check if it’s a corrupt file, open your backup project, since you’re using a beta build you have a handy backup right? :grin:

Thanks, but none of those worked either, without crashing

@Malachiman, Thanks, but none of those worked either, without crashing
By the way, the same crash happens when I try to open this project when using the non-beta version. Blocs 4.3.2

I would suggest submitting a download link to your project file as well :slight_smile:

@Norm, Check both the emails I sent you and your personal one. They have everything you need.

@Norm

I notice that when you use the Bootstrap ratio classes Blocs like to convert it to a video frame. Although these classes can be used for video and iframe, they are also used for Divs and Img. This is problematic in a current design I am working on, as I need it for images.

eg. This is a div with .ratio .ratio-1x1 applied.

1 Like

I’ll take a look.

1 Like

I don’t know how easy this would be to fix but I wonder why the bric selector pop up is suggesting brics from the store that are already installed when running a search.

Screenshot 2021-09-07 at 21.56.45

@JDW I’ll contact you privately regarding license activations :sunglasses:

Fixed in build 6

Is this in an alert?

Class info are not translated as they can be inputed by the user, no plans to translate the built in ones.

I’ll also look into the writer mode undo.

1 Like

The Bric ID’s the developer has added to the Blocs store don’t match the Brics ID.

You’ll notice ours don’t do that as our ID’s match correctly.

I’ve just checked this and you are right. It doesn’t happen with yours or a couple of the other developers. This seems limited to brics from @Whittfield as far as I can tell.

1 Like

Fixed in Build 6.

1 Like

That’s been my issues also with every Bric I’ve purchased from @Whittfield at blochead.dev. :frowning: