Blocs V4.4 Beta Build 6

Yes, it’s all new High Sierra support.
A fantastic feature to be sure, and one to rock the entire web design world.

Sorry, Norm, I didn’t see your note about that until just now. :slight_smile:

1 Like

I’m getting a missing font error msg when I start up some of my projects. It doesn’t happen every time, maybe only 50% of time for the affected projects. The error message only appears for a second or two, goes away, and the project opens normally. After that, I’m able to edit my project and there are no problems exporting. The only thing I notice in the font manager is that there are multiple sizes listed (100, 300, 400, etc) of the Lato and Open Sans fonts. I’ve attached a screen shot of the error message I get right after opening the project.

1 Like


Using my MBP with Catalina on an external drive (where it can do no damage to my beloved 32-bit apps), I tested Build 6 today. (Still working fine as a Trial, so no need to Activate it.) Here’s my report…

  1. Second line of Japanese shown in the sidebar is still truncated (new document, no content message)…
    It’s truncated at せ but it should end with せん

  2. When opening a New Document and hovering the arrow pointer over the little “+” icon, the tooltip is translated but the container is horizontally too narrow, forcing some text to a second line that is truncated.
    Pasted Graphic

  3. These two contextual menu choices I mentioned previously are still not available in Localazy, so they remain in English:

I see you made a lot of corrections since B5, by the way. Great job!


If I am looking at the classes window in the side panel and a class is present for a bloc that’s fine. Now I can change the page with the page selector above and the page changes as you would expect with all new content, however that same class is still shown in the classes window, which is totally misleading.

The only way to know what is really present is to physically click on the editing canvass, which then reloads the actual classes that are present for that bloc or item.

When changing a page it really needs to update what is present in the classes window at the same time or it can lead to big errors. Obviously I am referring to the dynamic area in this case.

Is this the Class Editor you are referring to?

The classes window in the side panel. I’ve been applying this hero-bloc class to the bloc immediately under the global area on every page to work with Smart Nav and as I changed pages I noticed that it looked like the class was already present, even though everything else had changed.

Screenshot 2021-09-14 at 16.23.15

1 Like

Thanks I’ll check that

Actually, I am taking care of that with the bric. It works great, but it’s actually just the ground work for another enhancement I’m working on.

I wasn’t suggesting it was the bric that was wrong. This looks like a general issue in Blocs that I only spotted because I was adding the same class on every page.

As new pages were loaded the hero-bloc class shown in the classes window still appeared to be present, even though nothing on the editing canvass had been selected. At a quick glance it was too easy to think a class was in use where it hadn’t been applied, so ideally that classes window in the side panel should be empty whenever a new page is loaded, until the canvass is selected and then load what is relevant to the selected area.

I think blocs may currently select the firs Bloc on the page when a new page is selected. But I’ll check that

Just checking this and the sidebar is populated with the first Blocs on the page, so the class editor should be displaying the correct data, however, the layer tree is not initially setting active layer.

This may be causing some confusion.

In practice I change to a new page and the side panel appears to still be showing class information from the last selection on the previous page. When I click on the canvass it then clears this but if you were going through various pages like this it would be easy to make a mistake.

Just a thought but I wonder if it matters how the page was selected. I was using the toggle switch at the top right hand side of the interface. Not the page navigator.

I’ve just patched dup the selection issue in the layer tree.

Is the section you are referring to in a hidden global area by any chance?

oh now I get what you’re saying. good catch.

I wondered about that, but I don’t think so. I was just following what Whittfield suggested to add the hero-bloc class to the first bloc below the global area and the blue line above is clearly visible.

When I hover over the global area above a message saying anything above that line is in the global area appears. I also clicked on the various sections inside the global area and none include that hero-bloc class.

Could you send a full screen shot of the page when the wrong class token is showing in the sidebar.

Also how are you identifying nothing on the page is selected?

Just looking at this again methodically and when I open a new page the first bloc on each page is indeed selected, however this includes the global area where present, which is potentially risky, so I would suggest it should be the first dynamic area bloc that is preselected.

Now I am trying this again and struggling to reproduce the same error, whereas yesterday it was quite evident. This may be one of those times that pop up occasionally where restarting Blocs clears the issue.

When changing the pages yesterday with the page selector it was almost like Blocs ceased to be the active app momentarily, because there was a subtle shift in the page contrast that changed when I clicked on the editing canvass. That is not happening now.

Recalling the workflow at the time I was finding it a hassle adding that class manually to 100+ pages, so I tried pasting the class name each time with a cmd + v before moving forward to the next page and I am wondering if that caused issues.

1 Like

Blocs takes that into consideration, it will select the first visible Bloc on the page. However when you switch pages the layer tree doesn’t show a selection, but there is one. Ive fixed that ready for the next build.

1 Like

Only since you mentioned it now I notice that on 4.3. The layer tree flashes blue and then goes. Interesting.

1 Like

Not for much longer :sunglasses: