Burger menu not visible

Hello

I have a website in French and by copying it and translating it page by page I also have a website in English. I am faced with the following problem and I don’t know where it is fixed. In English the hamburger menu is perfectly readable because the colours are contrasted.

On the French website, the same menu is almost unreadable because the colours are not contrasted.

However, the English site is a copy of the French.
In short, where can I change this?

You can access my website here: www.lemoulinduboisset.com

Thank you for your help

There is already a huge problem in the menu I have 2 times the same menu.
Have you cleared your browser’s cache?

yes I did it

Hi @Pat

A quick look shows you have the opacity set to 0.1 on the French site and 0.7 on the English one. I would suggest you have a typo here.

Hello

I don’t know where I put this setting. Probably in a classroom. I can’t find my notes anymore. Can you remind me which class is used to change the appearance of the menu?

Thanks

Hello @Pat I think it should be in “dropdown” or “dropdown-menu” classes…

Sorry
I come back with my problem. I don’t remember what class I had modify to to have this color. Maybe .dropdown-menu but between my website in french and my website in english its’s the same parameters.
I need help please

That’s the culprit:

\

It’s like @Malachiman Pete already spotted correctly.

Once I set the opacity to 1 (like in the screenshot), the background color changes to white. Seems only to be needed at XS breakpoint. Background shows white when the width is above 575px.

Bit tough to tackle and change the code due to those nasty hover-dropdowns on mobile.

1 Like

The problem that I don’t remember where I can set the opacity to 1 in blocs. In .dropdown-menu class it doesn’t work.

The class I changed (see screenshot) is .dropdown:hover .dropdown-menu:hover. Not sure if you have that in your class editor somewhere. And you need to set the background color on the XS device.

I can’t do it. I can’t change this class. Maybe a bug ,

Do you have it in you class editor?

No. I create the class each time.

So I fixed it by copying the css style from my English site and putting it in the directory of my French site. It works and that’s good for me because I don’t have time to search at the moment. Our guest house business takes too much time. I will look again this winter when the tourists will be at home. Thank you

Glad it works for you. :slight_smile:

Hello,
I’m back with my problem that I had solved temporarily by putting the CSS style file from the English version to the French directory. Now that I’ve switched to bootstrap 5 and merged the JS and CSS with Blocs I can’t do that anymore.
So I still have a setting in the French version of my site that makes the menus unreadable in XS (and only in XS mode). Where can I change this setting and put the background in white or light grey?

Thank you for your help.

Don’t merge. It creates countless issues (errors) and has no benefits.