Button Link to external URL doesn´t work on Mobile


#1

The Link works fine on the mac, but not on a mobile device (tried under all common browsers).
The green text Link works well.

Any suggestions very welcome :slight_smile:

Cheers Kilian


#2

SOLVED
No reaction vom Blocs so will put it under BUGS.
It´s a major thing wanting your ROWS or other design copied.

Any COPY of Button will cause major destruction on Mobile.
Design eg as an Row including Buttons as Links can be “duplicated” but you than have to insert any single Button again and restyle it (major hassle , special if icon on Button as well).
One of many…
Still believing Blocs can make it


#3

I’ll take a look at this and see what’s going on. I may need your project as it could be project specific, if you can please send that via a direct message.


#4

Doing tests at my end and I’m unable to replicate this at all, there was a report a while back from @ScottinPollock with a similar issue that had us both stumped and is still unresolved. You may have found the cause based on your comments about duplicating, but I think there is some more to this than just that. Could you DM me the project file via the forum and do more tests on your actual project to see whats breaking.


#5

Hi Norm,
Please find the PF on DP

May I ask another question:
How to set a link to a certain position on another Blocs Page (or even another Project - like setting anchors)

Have a good day

Lutz Kilian


#6

@Kilian you would need to use a URL interaction and set up a standard anchor link, you would just need to know your sites live URL, once the site is live it would work.


#7

@Kilian what are you using to test on mobile? An actual device or the browser?


#8

I tried this with #BLOC-3 as it was shown in the app on the left while working.
http://bluecruise.org/Gulet-Yacht-Charter/index.html#BLOC-3

Stupid me, adding the id of that bloc is now working.
http://bluecruise.org/Gulet-Yacht-Charter/index.html#bloc-3

Sorry for bothering a Professional

Cheers Kilian

Ps: there any news about my UI login?
ilcalsols@yahoo… is wrong / should be ilcalzola


#9

Sorry you have lost me, is this still an issue or just user error?

I’ll sort your account now.


#10

I try it both ways, with my ASUS Zen phone and moving the browser window on the Mac.
Results are different but one can live with that.

Let´s see how it works on tablet (need to by one these days).


#11

No issue, it´s working with the id in small letters.

Thanks


#12

@Kilian Im talking about the duplicate button issue not the anchor text question you posted in another thread.


#13

Oh, this is still an issue.

I rebuild each former copied button and after uploading those ones (the detail buttons on the site) are properly working on the mobile.


#14

But when you duplicate a button, it doesn’t work work correctly. Duplicated buttons work fine for me you see even using your project.

To confirm if you duplicate a button and then view it in a rescaled desktop browser, the button works fine, but when you view it actual device it doesn’t work?


#15

The copied button(s) work well on a screen before scaling.

After scaling the screen to mobile size they don´t work - just tested again.
http://bluecruise.org/Gulet-Yacht-Charter/index.html
On this site I rebuilt the first 3 ones.
The others were copied with the whole row (but I also tested to copy a solo button).
Those ones are inactive at mobile view.
Former I recognized a very small certain position on the very top off the buttons where they showed activiy.
But that doesn’t´t help if you want to touch on a mobile.