Can this be fixed?

I’ve asked about this before but had no response…

Frame - Small behaves differently at different breakpoints.

The frame should have a white border, but the smaller the device, the less visible (paler) the frame becomes.

With just one exception - the bottom one in the SM breakpoint screenshot, below. That is how the frame should look at all breakpoints, but all the other 40 or so photos on my website look like the top one.

I don’t think it’s me, so I’m assuming it’s a Blocs or Bootstrap issue.

Any ideas? Any fixes available?

Thanks.

www.poulson.info

I just tried that here and I’m not seeing that at all. It works as expected here at all breakpoints when I try in a Blocs project. I’m a bit pushed for time at the moment, but I’ll try to take a look later.

Thanks… can I suggest you drag the right edge of your browser window to progressively narrow the breakpoint?

I would expect you’ll see the frame grow greyer with each breakpoint, which matches exactly how it appears in Blocs. (Apart from the Joshua Tree photo.)

At least it’s consistent!

Seems OK here. I tried this on the local host as well using Safari and it was fine.

https://monosnap.com/file/QEr9RZSxmfx2mV5D4I95lx2LU2aA4N

That’s great.

But are we talking about my site, or your trial?

I’ve just checked directly on your website and there is a problem there, but I’d need to spend some time to work out what is wrong.

Try creating a fresh project with three columns like that and add a small frame to each image, then see if the same thing happens. If that works it points to something else in your project. As far as I can tell Blocs itself is working correctly.

I took a screen shot of same image (below) at lowest breakpoint and border appears in both, but the background color seems to overlay white border in top image. Hope this helps to isolate the problem.

Thanks @pruthe, that confirms the issue. One step forward!

Darn strange that all the smaller, same sized images have the problem, and not the unique wider one.

Hmmm.

I opened an archived version from April and added the frame, it works fine in Blocs and Solis (top screenshot).

But in Blocs and Solis, my current version does not work (bottom screenshot).

So something has changed somewhere along the line, since April. Maybe a Blocs update has caused the frame to not work as it should?

If your old version works fine in the current version of Blocs that means Blocs is fine. It’s something else you have done. Try deleting those elements and adding them again.

“Something I have done?”

I’ve used Blocs, that’s what I’ve done.

No way am I doing yet another rebuild because of a problem with Blocs, I’ve already done way too many of those to overcome glitches, as have others from reading the Forum.

If @norm has nothing to say, I’ll just leave it broken. Luckily it’s only a hobby website, not a commercial one.

Thanks anyway.:christmas_tree:

I mean done something like adding a custom class. Speaking of commercial websites I have to finish four by Christmas for clients, so I am bit rushed at the moment. You wouldn’t have to rebuild those sites, just try changing those bits.

I’ll take a look. What page does the item appear on?

It’s on the home page. You have click on the red more info buttons http://www.poulson.info/

1 Like

Found the problem, as @Flashman mentioned you have a custom class added to those images, that is causing the border to not show.

The class is info-photo

It has a custom class border style set to none and additional top padding on the SM breakpoint, it also sets the background colour to transparent on the larger breakpoint (which cascades down across all breakpoints).

This class is not generated by Blocs, it’s been generated and applied at some point by a user.

I hope that helps.

Thanks @Norm and @Flashman, I’ve just discovered the same thing - @Flashman gave me the notion of checking custom classes, which I hadn’t thought of.

A quick and easy solution, phew.

Appreciated!

1 Like

No worries, the bigger a project gets the trickier it is to keep track of all the styling and parts that are in play. We’ve all been there!

Glad you are up and running again.

1 Like

Yep, thanks again, it turned out to be a completely useless Custom Class. Duly deleted!

1 Like