Can't add video asset [SOLVED]


#1

So, I can’t add my video, a dialog about “background videos under 10mb” comes up and cancels my import. I’m not trying to use it as a background, it’s for a video object. It’s an mp4, and it’s already streaming optimized. I need to use it, why won’t Blocs let me?


#2

It should let you add any size video, the video limit has been lifted in 2.3.1. How are you adding the video?


#3

I inserted a video gallery. Then selected the first video. Then in the sidebar, i set for “local” then clicked on the video source. It brings up the asset manager, where i press the ‘+’ and navigate to the video i want to use. It brings up the dialog about background videos and dismissing it cancels the import. I’m running 2.3.1.


#4

Seeing the same thing here with a standard video bric selected in 2.3.1.


#5

BTW it also does the same thing trying by just trying to use the asset manager directly. My video is 47.8MB


#6

Try dragging a video onto the asset manager. The add button may be acting up.


#7

That worked. Same message about background video, but it’s in the assets after you press ok.


#8

I’ll fix that up in 2.3.2


#9

I’m having the same problem and not solved by dragging it to the asset manager so far. It’s a 1080HD video that is 16MB. This is in Blocs 2.4.4 trying to add a single self hosted video using the video bric.


#10

I eventually got it to work, but that pop up message looks like the bug is back.


#11

I can’t seem to add .mov or .m4v video to the asset manager. When I click on the + of the project assets section the videos are grayed out so I cannot select them. When I try to drag to the project assets, the drag fails – nothing gets added. When I try to drag a video directly to the brick, nothing happens. However, when I drag a video to the little thumbnail in the rightside panel, the video does appear there – however, it won’t appear in the project when I try either to view it, or open in a browser.

I’m using 2.4.5, but I just downloaded beta 2.5.0 b4 and I get the same result.

The animated gif demonstrates many of the above problems mentioned above. It’s separated into 2 parts because of the 3MB size restriction.

The gif below picks up where the one above left off…

Thanks


#12

Blocs and the web only support video in mp4 format. I’ll put something in place to prevent the drag drop issue.


#13

Much thanks for the quick help. Afterward I did a search for “video format” and sure enough, it does say mp4 is the required format.

I was having trouble converting to .mp4. I ended up using ffmpeg (explained here). I’ve had video/audio conversion issues for years and can’t believe this tool is free.