Can't delete unused pages

I’m not able to delete an unused page.
Blocs 3.4.3 Beta3.
I tried various methods to delete, but no luck.

Unless there is an issue specially affecting the Beta version, the illustration below shows how to delete a page.

Thanks hendon52. Very kind of you trying to help.
There’re various methods to delete a page and I’ve tried them all.
And it’s also not related to the Beta. Same happens with the 3.4.2.

Very Strange. I’m using 3.4.2 and cannot replicate the issue. I’m assuming that it may be something specific to your installation. Maybe a reinstall of Blocs or a system reboot may do the trick.

Strange indeed.
I tried all tricks, but that didn’t solved the problem.
The problem must be project related.
I have projects were deleting pages works like it should.
I’ve sent a bug report to Norm.
Let’s see what he can find.

1 Like


I had the same issue (I think it was in 3.4.2). Finally I renamed the page I wanted to delete to something like “Temp” instead of the original name which was “Download”. Then delete was possible. At least here and at that time…

I also tried that with no luck.
But thanks anyway.

Do you have a search value in the page navigator?

Yes I have.
Norm I’ve sent you the file via bug report.
Must have been yesterday or so.

Try locating your page without using a search value then try to delete.

Found it.
I had to delete ALL page settings like SEO title etc. first and rename the page.
That did the trick.
Thanks all of you.