Can't preview site in browser

I am running the latest version of Blocs and have just updated my blog but for some reason I can no longer view in browser, either Chrome nor Safari. Currently also on the latest version of Catalina. I have tried a reboot of my MacBook Pro to no avail. Can anybody suggest what else I might try please?

Thanking you in advance.

Sabina

also now when I try to export project all my pages are in .html format. See attached file. How can I rectify this please somebody.

I assume you had clean URLs selected before, and this time you did not?

Clean URLs would enable you to have something like this

www.mysite.com/blog

instead of

www.mysite.com/blog.html

Thank you. Can you please tell me where I might find “clean urls”?

You can set it under Project Settings, there is a tick box for it under the 7th tab icon.

Or when you export

File - Export - Export Project

Then tick Clean Page URL’s

but I still can’t view site in browser for some reason.

How are you trying to view it? Your website appears to be online no problems.

I’m trying to view the two new blog items from within the project file which I have spent all morning trying to upload to site. I unticked the “Clean Page URL’s” and that seemed to work. However, previously I have been able to view my site in browser before exporting and uploading. For some reason or other I can no longer do that.

Now it won’t export the project file which I created this morning with two new blog items (one Japanese and one English). I have tried unchecking and rechecking the “Clean Page URL’s” but just getting the same all .html files. What am I doing wrong or is this a “bug”? I know our currently loaded site is up and working but I can’t upload a reworked version with new blog items for some reason.

At last I have the site reloaded. I have been working on updating 2 blog items since 2.30am this morning and it is now 1.30pm. I have to say that I have never had this much problem with Blocs in the past and guess it just happens to be my bad luck. Thank you. However, it still hasn’t solved my problem of not being able to “view in browser”. I just wonder whether anybody else has had this problem or is it just me?

It is strange.

Have you looked at Volt for managing your Blog? It would allow you to update in the browser on your live site.

@InStacks has created a very good product. https://blocs.store/product/volt-cms/

1 Like

I had thought about it but I don’t know anything about it, nor do I cherish the idea of transferring everything across. Might look into it though although it still doesnt resolve why I can’t view my project file in Chrome or Safari at that.

1 Like

One very happy person. Just installed the latest of Blocs: 3.5.7 and the “view in browser” function is restored and exporting proceeding as is expected. Thank you Blocs team.

3 Likes