Card Designer 1.4.6 issues

Is anyone else experiencing the following (using Blocs v3.5.1, and CD 1.4.6):

Problem 1) Font Selection
Observed behavior:
I can’t seem to use any font other than the default font (seems to only work with the default font, which is based on project font). This problem isn’t visible from the design canvas view(it appears correct in design view). It’s only observable once you preview the page in the native preview, or from a web browsers. Also, if the font is changed from the default (Helvetica) the resulting font always shows up in preview as Times Roman. Another observed odd behavior is that a document saved using CD along with a different font (other than the default), will open and appear correctly in the design view, but the font name in the text font selection fields always appear as Helvetica instead of the actual font used in CD.

Problem 2) Text Truncation
Observed behavior:
Text information for Title and Description is always shown complete (as long as it’s within the specified character limits which is title=70, description=90) when using 1 background image. But, once a second image is added, the title and description is truncated if it’s over approximately 30 characters. As with problem #1 above, this is NOT visible from the design canvas view, it’s only visible when previewed. The truncation doesn’t appear to be consistent in terms of the number of character (~30-35), but it’s certainly well below the specified limit.

I’ve spent a bit of time trying to narrow down the specific conditions that trigger these behaviors, and whether they’re repeatable, and for me these issues happen 100% of the time.

If necessary - I can provide screen shots, or even a Blocs document.

Any help in this matter would be greatly appreciated.

Hi @MiguelR, in regards to problem 1 I’m having the same issue. I have reported this to the developer @Whittfield several weeks ago who believes it’s a Blocs issue. From here support has stopped without any (soon to be expected) solutions to the problem. I’m aware there’s a way around it with custom classes (which can be found on the forum) but from a principle, I will not be going this route. Being able to change font size is to me basic for a purchased product and therefore I’ve stopped using the bric.

Thanks @Jerry. I’m aware there’s a manual workaround, but considering Blocs, and CD are paid products, it’s a little disappointing when basic functionalities don’t work and forces you to spend additional time working around these issues using a manual process (which I may have to then come back to latter when, and if, a fix is provided). For this reason, I find it difficult to use a crippled custom bric in a project, which defeats the purpose of getting it in the first place. But I understand that’s the nature of the beast in regards to FE development.

@Norm, @Whittfield, Just tried the same in the latest beta (3.5.2.b4) and both issues persists. Hopefully there’s a fix in the next update.

1 Like

Luckily I’m still using CD 1.4.4 and it seems to be working okay in Blocs 3.5.1. Is there anyway you can uninstall the 1.4.6 and go back to 1.4.4?

Thanks @StephenHutchinson.
Just tested this by creating a new document using Blocs v3.4.2, and CD v1.4.4, and both issues still happens. Just out of curiosity, what OS are you using? I’m using HS v10.13.6

Thanks anyway,

1 Like

… just in case you’re wondering - I’m officially using Blocs v3.5.1 and CD v1.4.6, but reinstalled these earlier version just to see if the same issues still occur.

@MiguelR All issues you described in the opening comment persists with Blocs 3.5.2 beta4 under Catalina 10.15.6 with CD 1.4.4. and 1.4.6.
Also the option “make card clickable” does not work at all.
I sent a PM to Whittfield but got no answer.

Thanks @Bootsie, and thanks to all for your comments on this topic, much appreciated. It certainly is a pity that there is no general response to these issues. I get that there might not be an easy answer, but complete silence isn’t reassuring either that future updates (or products) will not be met with the same level of support.

If there is anyone else out there experiencing these particular issues, you should voice it. Otherwise, if it’s only one or two out of possible tens or hundreds of users, it might not be enough of an incentive for the developers to look into. This hurts both the user and developers in the long run.


1 Like

Hi @MiguelR

Sorry to here you are having those issues. Do you have another bric such as Swiper running along Card Designer ? Read there may be conflicts when using both.

I have not myself experienced such an issue with using CD and have used it in all my projects. Though perhaps my title and description are not long enough. I have been able to customize most aspects to my needs: fonts, colours,etc. I am using Blocs 3.5.1 and CD 1.4.6.

Here are two examples:


I have never had this problem with CD in particular I use it in most of my projects when necessary.

What I have experienced with all the brics is that some of them cause conflicts from time to time or if you use a code that can conflict as well !!

In particular, the developer gives you assistance in a few hours, keep in mind that due to the situation, COVID may be offline, but assistance always comes!

If it helps you can send me your project by MP and I can search if there is any probable cause to discard.


Thanks @nelo and @MDS, I appreciate you reaching out.

Interesting that you (@nelo) haven’t had this issue. Luckily the project I’m currently working on isn’t using CD, thus not affected by it. But because of it, my use of this tool seems limited, or not at all.

When I mentioned previously about me testing the aforementioned issues, I was aware of custom blocs/brics possibly stepping on CD, and so I created a new document with nothing but a basic one column bloc and the CD bric. I also tried it in earlier and recent versions of Blocs and CD, and I still come across the same issues.

Anyway, if anyone is interested in what I’m seeing, here it is…

Hi Miguel @MiguelR

I have done some testing and indeed there is quite an issue here.

I played with @Whittfield original provided CD bloc sample and even his cannot be modified.

I have checked the files that are supposed to attached to the page and either all are missing or sometimes only the js files. Even when I export to a local folder the files appear to be missing now.

Cannot say for sure what the issue is, my latest blocs update is 3.5.1 on June 23 and the last time I used CD was on July 14 with no issue. I am going to update with Catalina 10.15.6 and see if it resolves the issue.

@Norm you may want to check this ? Really easy for you to replicate. Thanks


1 Like

Thanks for taking the time to validate.


Another interesting thing I noticed…

When setting up a basic card, with a title and description along with two images, it produces the truncation(already known). Never mind changing the font (that’s a separate issue).

But now, once this happens, by detaching card-designer.js (only detaching this file, not cd-swiper.css or cd-swiper.min.js) from the page, the text is then no longer truncated. And as soon as you add a second image (again), truncation reoccurs (as card-designer.js is reattached to the page).


I certainly can’t replicate the flaw you comment on or any other flaws read in the comments, which is very rare I guess.

I leave you an image of how this card looks in blocsapp and I leave the link to the previous one online so you can see that everything works correctly

Aquí you can see it live

Having a file with the mistakes you make would be great, to see what it could be!

Thanks @nelo.

I’ll put together a simple Blocs doc that (from my end) shows the problem and see if you see the same.
Also, looking at the link you provided, I am puzzled by the fact the title does look like it works but on the other hand do observe that the description is being truncated.

Again, I thank you for your time in this matter.

Hi @nelo

To see the issue you need to change the text at least the title. However, some instances now I cannot even change the text…


FYI @Whittfield has always been quite reactive in assisting and correcting issues. However, with all that is going on in the US he may have other priorities…

We just need to be a little more patient.


@MiguelR @MDS

I don’t know what you mean by the truncated text (in particular, that text can be edited as you like, I think, I don’t see a problem). an example would be better to know what you mean

I have updated the link titles check it again, I still don’t see the problem …


Hi @MDS,
I completely understand, and agree, as I’m also in the US (NY). I’m not upset about this, just a little disappointed I can’t really use this tool (which I like) to it’s full potential on a more regular basis.

And if it seems I’m being impatient it’s that I also want to ensure the problem is not local to me (where I might be able to do something about, instead of waiting), before I go ahead and assume it’s the tools themselves.

I also don’t expect anyone on this forum to volunteer their time, but if anyone else is experiencing these things, and want to also certify there is a problem, then it’ll certainly help both users and developers, which is another reason why I’m grateful to other members for helping disproof or validate issues.

Besides, this thread could help @Whittfield or even @Norm narrow down the problem if there is enough details to help track.