Changed site to https and now no Googlefonts


#1

Hi all,
I added a security-certificate to my site and now its using https:// to enter.
Problem now is: Googlefonts are not loaded anymore.

I found a solution to bypass this, but is it possible to change this in the project settings ore somewhere else?

found solution:
link href=‘http://fonts.googleapis.com/css?family=Dosis:400,700’ rel=‘stylesheet’ type=‘text/css’

and change it to this:

href=’//fonts.googleapis.com/css?family=Dosis:400,700’ rel=‘stylesheet’ type=‘text/css’>

This simple change will make your browser call the Google Font page in the applicable mode (HTTP vs HTTPS).


#2

@Norm: is there any way to automate the change to the ref to the Googlefonts?


#3

Change link href=‘[http://fonts.googleapis.com…etc. into link href=‘[https://fonts.googleapis.com … etc… So change http into https. It worked for me.


#4

The problem with changing the html is that I am afraid I would have to do this on any page.
The only way to use Google fonts is to check ‘use Google fonts’ in project setting.
So I have found another solution: adding a file in css: google-fonts.min.css
With this code, in my case I used Varela+round,you can change this for any Google-font you are using.
and it will work.

@import url('https://fonts.googleapis.com/css?family=Varela+Round');

#5

The better way of doing this is to physically download the same Google fonts and add them to the project as hosted fonts. The problem disappears that way. https://developers.google.com/fonts/faq#can_i_download_the_fonts_on_google_fonts_to_my_own_computer

You will probably have to convert them to web fonts and then add them via Blocs preferences. https://help.blocsapp.com/knowledge-base/font-manager/#adding-new-local-web-fonts

I always use local fonts, rather than relying on external services.