Delete images in Asset Manager

Hi guys

How to delete completely the images in the Asset Manager?
I could delete an image but next time I open Blocs the image appears again, even if I delete that image on root of it, mean, Application Support, Blocs 2, tempAssetStorage, etc.
This is very annoying.

Thanks in advance.

Hi @Francisco

Make sure you are running the latest version (2.6.2) Check for it in Blocs : About Blocs

Open the Asset Manager (7) & then select Project Assets & then right-click on an image and select Delete. Then save the project. Works for me.


Thank you Bill for your answer. Doesn’t work for me.
Btw, theres is no Delete option… it is remove asset, right?

You normaly just have to right click on the image you want to delete and the option “Remove Asset” will appear.

Like here.

Thanks Muppet but doesn’t work in my case and I do not know why.
I do not know why the images continue to happen in the project.

Are you trying to delete the default images that come with the app? I’ve not tried it, but that may not be possible. I avoid those by having a folder for the project, rather than viewing all.

Thanks Flashman!

Yup, I have seen this too. It allowed me to use a JPG that the pop-up said was too large. I resized it and then couldn’t replace the ‘asset’. I renamed it and replaced it that way.

I also noticed I can’t use an asset file with ñ in the name. This isn’t a huge deal but for a Mac app, I was surprised!

1 Like

Did this ever get resolved.
I still have assets showing I don’t use.
I can delete them but they show up again, but the ‘show in finder’ doesn’t work.
I can’t splat this pesky bug!!
Is there a way to dig into the folder tree to get to them outside of Blocs?