Deleting links in Primary Menu

I have added pages, forgetting to untick the Primary Menu item so have got unwanted page links in the Primary Menu. I do not seem to be able to get rid of these! How is it done?
Also I would like to change the order of some of the items but cannot work out how.
Any help would be welcome

Hello Malcolm,

Select the navigation list and click on the Menu Manager in the sidebar, from there you will be able to change or rearrange the links.



HI Eldar
I can remove them or reorder them in the Menu Manager but the changes are not reflected in the Primary Menu. I have saved, quit and restarted and viewed in browser (Safari) but Primary Menu does not agree with Menu Manager. Even if I delete the page it links to entirely, the item still shows but then links to the home page.

Click on the navigation list and make sure that the source is set to ‘Primary Menu’. If it set to none, then you can edit the menu items manually.


Hello @malc, set the source to None and then back to Prinary Menu, this should update the settings.

Great! That worked. Thank you.

1 Like