Disappearing global header bloc

I have a strange problem, a disappearing header bloc in the ‘global’ area of my site page.
When I say it has disappeared, the bloc itself is visible on the page, but it has disappeared from the object tree list on the left of the screen. See attached screenshot.

This is not the first time this has happened to me. Last time, I had to completely re-make the bloc. However, I just wondered if there is a means of recovering its appearance in the ‘object tree’? Does anyone have any ideas? (I have already tried saving, closing Blocs, and restarting… but it’s still not there!

I need to recover this if possible as I still have to add the correct links to the header graphics!

As usual, any help appreciated!

Hi again,

Should @Norm take a look at this one, here’s my system spec (screenshot).
Screenshot 2020-05-29 at 23.37.33

…and using Blocs 3.4.10.

That was what worked for me. I had this happen for the first and only time the other day. (I made a backup on my project prior to saving though), the save and reopen fixed the sidebar in my case.

Submit a bug report to Norm, and if you can include your project file. Sometimes if the project file has got stuffed he can restore it.

https://help.blocsapp.com/knowledge-base/reporting-bugs/#bug-report-form

Hi @Malachiman,

Thanks for your reply. Have now reported this as a possible bug.

While not absolutely certain, the last thing I did before I noticed that the Nav bloc had disappeared was to apply a -8px margin to the nav container to push the menu graphics up to the top edge of the navbar and then saved the file. Just wondered if you did something similar?

Finally, I just tried a ‘Save as…’, close and reopen to see if that would restore the ‘missing’ bloc, but no luck there!

Hopefully @Norm will have a solution…

@Norm confirms this problem will be fixed with update 3.5.1 due shortly.

2 Likes