Does Animation Require Additional Programming?


#1

Having one of those weeks with Blocs where I can’t seem to figure out something that I’m sure should be actually very simple. I can’t get any aspect of the application’s animations to work correctly. When I apply an animation as an on screen effect with a direction and slight delay, Blocs shows me what they will look like immediately after the setting but not in preview mode, nor when previewed in Safari or when applied to a live demo site. The HTML and CSS files the project creates look correct and so I’m at a complete loss why this isn’t working.

Is there any additional preference or project settings required here? Does the project need to be exported differently for work that includes animations? Does any changes need to be made to the HTML or CSS files to bring these effects to life.

Super stuck here.

Thanks

Michael


#2

Is this Blocs 2 or Blocs 3? I had similar issues with Blocs 2, but version 3 should be reliable. If you post a project file or even just a single page with this issue we can take a look.


#3

I’m using the latest version of Blocs (3.1.2) on a Mac running Mohave (10.14.3). Here’s a test page I’ve been using to see what I might be doing wrong.

Thanks so much for looking into this!

Animation Issue.bloc (725.6 KB)


#4

It seems to work fine here.

screencast%202019-02-27%2016-19-58

That was on High Sierra with the beta of 3.2. I’ll try 3.1.2 in a while. I have to run out quickly to grab some shopping.


#5

Very strange. Most likely something on my end. An issue with Mojave then? Again, animations don’t work after exporting a project and copying all files to a dev environment.


#6

Works fine here in 3.1.2 as well. If this was a general problem I think everybody would be shouting about it, so most likely something particular to your setup. I would send in a bug report including as much information as possible. You could reference this thread as well.

https://help.blocsapp.com/knowledge-base/reporting-bugs/#bug-report-form


#7

Sounds like cache.


#8

Hey Norm,

Would this still be the case after a system restarts over the past several days of working on this issue? Unfortunately for me, I’ve yet to get any Blocs based animation to work since I’ve begun using the program. Could it be how my system is configured? It certainly feels like something on my end - I just don’t know what would block (pardon the pun) this specific feature like this.

Michael


#9

Did you ever use Blocs v2 on the Mac?

I’ve had one other report months ago and it was the updated version of animate.css file just wouldn’t load. When he revert the animate.css file to the older one Blocs v2 uses, it worked.

It’s one of those really hard ones to trouble shoot as it technically wasn’t causing any errors.

It may actually be an OS setting applied to save battery, I never figured it out.


#10

Correction: not cache. Cleared everything on my machine and animations still don’t render. But they do on other systems I have access to. Mojave then? I’ve only been using the latest version of Blocs. Happy to entertain using an older animate.css file if that might help.


#11

@blocman94, i have the same issue with Safari for a long time ( cant figure out the problem must be local, strange because its on my iMac and my Macbook), i use chrome to preview now standart and all animations are working. so try chrome for a test, i am interested in the result.

just checked your blocs file, animation is not working in safari and in blocs preview, but the preview in chrome is ok


#12

Yeah, I wonder if it is a setting in Safari or a conflict from an app.


#13

I have the same configurations over one year, on both machines, I do remember that i have bin testing some webkit animation scripts ( external stuff) maybe that is thing. I am wondering is there a sort of reset for the webkit of safari, or reinstall?


#14

Maybe. Im not sure.


#15

Hey Sandy,

Chrome works and thus problem solved. Thank you! While it’s fascinating that other Mac based browsers don’t work, I gotta move on.

Michael