Downloadable asset not being exported?

can anyone help?

Creating a relatively large project and have found that one of the PDF assets is not being exported

I had to import the file individually outside of blocs, which is not ideal but when i do, it works fine.

what i have done so far:

  1. Created a new bloc for the buttons and completely recreated it from scratch.
  2. Cleared the cache
  3. Changed the name of the file
  4. and obviously as blocs isn’t exporting the document as normal i added it individually to my server

anyone (@Norm, @Eldar ) have any ideas why it may be doing this? i really cannot be adding everything individually, it would take so long

What’s the file name of the pdf?

The file name is:

2 medical regiment

Ive tried:

Chapter - 2 medical regiment

But no changes make it export, others with similar names do and i can see it in the asset manager, Ive deleted and saved the project, and then re-added it too. That didn’t work.

So i can get it to work if i do it as normal, but because it doesn’t export, i add it to the export folder myself then FTP to server and that works. Bizarre

I’d recommend creating a problem ticket and then sending your project file to @Norm for review. Previously, I had a problem with the export of a pdf file in my one project. I had created a list of about a dozen text links to downloadable pdfs, and for some reason, the last pdf in the list would not export. I was able to get around the problem by adding another unneeded pdf after the last pdf and then turning off visibility to this pdf, which allowed the previous pdf to now be exported.

I created a ticket and sent in my project file, but haven’t yet heard back about a resolution. At the time, in my problem report I told Norm that I had a workaround and it was not a big deal to fix right now. I’m guessing he had higher priority issues to work on and that’s why I haven’t yet heard back.

It’s possible that my problem and yours are related. Or it’s possible that the bloc my pdfs are in was somehow corrupted, so I’m planning to recreate the bloc when I get a chance to see if the issue goes away. Maybe you could try to recreate the bloc your pdf is in to see if your problem goes away.

Good luck in resolving your issue. :slight_smile:


Hi, thanks for that, good to know I’m not the only one. I have opened a ticket and hopefully will hear back soon.

Re creating a new bloc, i did do that, one of the first things I’ve done. But sadly that didn’t work, other pdf downloads on that same bloc work and download ok. All very odd.

Thanks for taking the time to answer

have you tried opening the pdf in preview, cmd+p and then saving as a new PDF with the same file name, overwriting the file and then dragging that into the asset manager so it forces it to be replaced with the new copy?

Not quite that process, however, i have opened in Acrobat professional, resaved it as a new PDF, deleted the asset from the project, resaved the project and then re-added the new file to it. still wont export it. i just don’t understand it.

Hi again @Recce43,

Do you have any downloadable PDFs as part of your Nav menu items? If so, try setting them to “No Download” and try an export. Do missing export PDFs now show up?



i don’t have any PDF’s as part of the Nav menu, all menu items direct to pages of the site.

But i do have pdfs in the same bloc that work and export just fine. ive even recreated the entire bloc to see if it will work. ive not heard back from the ticket i raised yet. but needing some answers soon as im reluctant to carry on much work if there are problems like this.

the only thing i haven’t tried is to redo the entire page, but its quite a big page, probably the biggest in the whole project.

Sorry you’re still having the problem. I tried some things yesterday on my project, but can’t determine a cause. The only way I was able to bypass my problem was to store a hidden unneeded pdf after the pdf that wasn’t exporting, as described in my previous post. Maybe you could try that trick after your pdf that does not export.

Hopefully, @Norm will get a chance soon to look at your ticket and find a fix.

Good Luck!


Thanks so much for assisting

@Norm - so looks like ive encountered this issue again - PDF not exporting. no matter what i do, it doesnt export. ive recreated the brick, ive changed the file (resaved it, renamed it, reduced file size). nothing seems to work.

any thoughts.

Hi @Recce43,

I still have a missing exported PDF problem for one older project originally created on Blocs 3 (now using B4). I have a page which lists a series of downloadable PDFs. For some reason, the last PDF in the list is not exported. I also tried different things to correct with no success. I’m guessing there’s a corruption somewhere in the project file. This is the only project that had the problem.

At this point, it’s simpler for me to just manually upload the PDF file to the downloads folder on the web site. I may try to rebuild the page later when I have more time. Or maybe the new Blocs 5 app will fix the problem when I open the project on that.

Good Luck with your project. :slight_smile:


hi, thanks for your message, its comforting to know its not just me, but sad that this is still going on for people. i have decided that it may be worth adding all my downloads to an offline folder on the mac, add any new ones to it, as well as add it to the project and then copy and replace the exported downloads folder from that one each time.

a ridiculous way around things that will ultimately take longer than it ever should, but with quite a few downloads, i cannot guarantee which are uploaded and which are not with blocs being temperamental as it is.