Export Package feature just doesn't work

Due to Corona I was asked to do home office. So I grabbed my SSD external drive (Samsung T5), went to the office, opened a blocs file and used the export as package feature. (no assets were embedded).

Went home, attached the drive to my iMac, opened the blocs file and this is what I got:

What’s weird is, the assets are showing up in the thumbnails, but not in design view. If I right click an asset it finds it in the finder in the package folder as expected.

If I preview the page this is what it looks like in Chrome:

By the way, this is not the first time I have seen this problem with the Package feature - I reported it as a bug a while ago. Now I’m confronted with the fact that if I want to work at home on this project, I will basically have to re-assign every single image asset. And the worst part is: When I package it again to move it back to the Mac at our office, when I open it there I will have the same problem. I know this for a fact because I’ve tried it in the past.

This is just one example of bugs that I have experienced recently, the biggest one being that Blocs was crashing constantly. Norm fixed that - THANKS!

I have refrained from posting all the problems and bugs that I’ve experienced in the last 5-6 weeks and ranting here in the forum. I know Norm is really working hard to get things fixed and I really value and appreciate this.

But I gotta be honest: I am this close to giving up on Blocs as a tool that can be used safely and with trust in any kind of company. I have lost so much time due to bugs that I’m afraid to add up all the lost hours.

I have to assume that any new feature has been tested before its release. But this one just doesn’t work for me - maybe I’m the worst Blocs user ever as far as my work flow goes, but you know what? I kind of expect that a software has been tested for people like me before its released.

I would be interested to hear if any other users have tried the Package feature and share their experiences. If I’m doing something wrong (which is usually the case :slight_smile: I will be the first to admit it!

Do you store the assets in a general resources folder next to the project file? If not this is a good practice and it should work for you by just copying across the general folder together with the project file and associated image assets. I have done this between two Macw without ever needing to create a package and it worked fine. I have also used the package feature without problems.

Hi Flashman,
Then consider yourself lucky! To answer your question, yes I put all my assets (except fonts) in an assets folder next to the project file, and have been doing so since day one - even way before I started using Blocs. Take a look at the screencasts I posted. Does that look like something you get when you package a project? Well that’s what I’m getting here.

The package command builds a directory structure and copies all the assets to a directory. That works fine - ALL the assets ARE there. You can see them in thumbnail view. You can see some of them in the previewed page. But not in design view and not in the assets manager. Now does that sound like a problem regarding where the original assets are stored in relation to the original blocs file? Sorry, not making sense to me.

My projects look like this:

Project Folder/
project.blocs
Assets Folder/
all Assets except fonts

And yea, I also tried just copying everything - many times, a long time ago, and that never worked for me at all. I also reported that as a bug a long time ago - I guess around version 3.2. And I assume that one of the reasons the package feature was added is because of the problems myself and others have had with “just copying”.

Last but not least: I am, quite frankly, pretty frustrated and fed up at the moment. I have never really had a 100% feeling I could trust the software. And it’s only out of a love for the genius and simplicity of Blocs and the great community here, that I haven’t “jumped ship”. I personally feel that Blocs is a real game changer - the prefect combination of code + creative design … if only it were stable.

I know this will probably get me some flack for saying, but while a lot of issues have been fixed, it seems to me that with a lot of the new features the level of “instability” has not changed. If it was up to me, I would not add even one more feature until all verified bugs have been fixed!

I’ve had mail conversations with support regarding this issue in the past, and was asked questions like "are you saving on an external drive? Or “Are you using special characters in your folder or file names?” And while I do agree with you that there are some “best practices” that can be suggested, I still kind of have to ask “Seriously*?” That should not make a difference, sorry! ALL my customer files are stored on external drives. That’s my particular workflow, and I kind of expect a software to be able to deal with that.

Another example of a major bug I was having is that Blocs was crashing like crazy. This went on for at least a 3-1/2 weeks. I was asked "What exactly were you doing when it crashed? What kind of CSS where you editing in the editor? Where are you saving to? etc. …and while I realize that such questions are important for support to get a clear picture of the problem, nevertheless it turns out the bug was found and fixed in the end and as far as I understand it, it had nothing to do whatsoever with my system or the way I work: “So after a bit of research it turns out NSCollectionView part of the MacOS SDK has a long standing bug that Apple haven’t fixed yet/”

Gary,
Frustrated in Germany

Late night update: I just found out the following: if I choose an asset that appears to be missing in the asset manager and select “embed”, the asset “magically” appears in the asset manager and on any pages where the asset was shown as missing in design view:

I work the same as you, however I keep active projects inside my user folder on the main drive with the OS and it all works perfectly. After projects are no longer in active use they can be moved to external drives for storage purposes.

I suspect the issues you are seeing are more down to security related issues in the OS than Blocs itself, because Apple are becoming progressively stricter with each update. For example it causes problems if the user folder is not on the same drive as the OS. If your particular workflow conflicts with the OS requirements it’s likely to cause problems.

Are you running the project from your Macs HD and not the thumb drive.

This is what Blocs says about the package feature: https://help.blocsapp.com/knowledge-base/package-a-project/

" …transport the project in its entirety to other Macs"

So I see a discussion of about how or where I store my work to be of little benefit here. Nevertheless, just for the record:

  1. Packaged a project that was on the local Mac HD of another Mac in another location.
  2. Copied the package folder in its entirety to an external SSD
  3. Brought the SSD back home and plugged in the SSD to my Mac at home
  4. Opened the Blocs file located on the external drive.

The documentation says: “transport the project in its entirety to other Macs”. So how do you suggest I “transport the project” to another Mac if I shouldn’t copy it to an external drive? E-Mail? Cloud?

AND: I also tried the following with another project, this time keeping everything on the local MAC HD:

  1. opened a project located in /User/Projects/MyProject
  2. created a package and stored it in /Documents/Package Folder Name

Also doesn’t work.

So in summary, I having problems with projects packed and saved on an external drive, and with projects packaged and saved on the same local drive.

Quite frankly, all of these discussions should not matter. All my other Apps (Adobe, Bootstrap Studio, Office for Mac, etc. etc. …) don’t have these kind of problems.

And in the end I’m just trying to do what Blocs says in its documentation. There is no documentation whatsoever which says “Warning: please do not use external drives”

While it’s located on a separate HD to Blocs its technically still in transit and this may be the issue that is causing the missing images.

By move to another Mac it means copy it to the root Mac HD, I would try that just to see if it works.

Thats because they are all created differently and use different tech to power the file format and also a lot of those apps also embed all the data into the project files.

It sounds like you may be encountering a bug, with the package set up, so yeah it’s not covered in the docs for obvious reasons. We just need to find out what is causing the issue so it can be patched up.

I have been able to cause the asset to break in the current release of Blocs by simply opening a project with asset paths that need reconnected (packages work this way to)

Moving the package to the actual Mac HD (off the external drive) caused the images to load).

I’ll investigate why this is the case, it could be a number of things, or even a long standing issue. I’ll let you know when I have more details.

UPDATE

I have found the cause and have patched it ready, moving the entire package directory to your local HD will also make the project load correctly in the meantime.

I have had similar issues also and reported it back many times as good as i could (via videos showing the issues), and this often with good response from the developers. But now I don’t report these things anymore as the patches/updates do not have seemed to help. Instead, I simply keep everything in the place where I last stored it where it was “safe”. I agree about the instability issues, some times many things are like crazy, to me not “logical” functions with BLOCS. I can not and will not try to explain this better than this. I love BLOCS in many ways, and have also stayed because of similar reasons, but some stuff seems like weird many times, and I don’t often trust the software anymore, I’m always ready something strange will happen when saving or doing some edits, also after watching many of Eldars good movies which I think I most of the times understood. Good luck, Gary and Norm, I hope you can solve this little adventure :slight_smile:

Well Ive just found a little cluster of issues with assets and projects hosted on external drives, so hopefully 3.4.5 will be more stable for you going forward.

I have found the cause and have patched it ready, moving the entire package directory to your local HD will also make the project load correctly in the meantime.

Just tried it … did not work.

1 Like

Here is a video showing the results I get when I copy a package folder to my local drive and then open it:

1 Like

Here’s the last video I made before giving this up, after 1 or 2 patches from Norm if I can remember it correctly. It’s a lot of variants tried in this video, maybe I do it all wrong. Anyhow, in the end I stopped speaking, as frustration showed up for real I think. My apologies for that, I hope it’s possible to understand something anyhow. Rock’n roll.

Any chance you could send me that package so I can try it here on my Mac?

I’ve had issues with assets too and there’s been some back and forth with Norm over the past 3 weeks over it.

I’ve worked remotely with Blocs for a couple of years without issue before the package option came up by just copying the project file and separate asset folder to an external drive. I was using a bit of software to clone the relevant directories to an external drive and then just mirroring them back again when I returned to the main desktop computer. I’ve had no issues at all working this way.

When the package option came out I thought this would save me a few steps so I tried embedding and exporting a package but ran into similar issues with assets not being visible in the manager yet appearing in previews and the export folder.

Based on feedback from Norm I’m confident this particular bug will be squashed soon. Until then my previous workflow remains solid.

Don’t embed and package. Do one or the other :+1:

“Don’t embed and package. Do one or the other”

Could it be possible for you to code BLOCS so that combo will be impossible, if so?

“Any chance you could send me that package so I can try it here on my Mac?”

If it could help, no problem. What file/files do you want? Only the file “HEA-2020-02-07.bloc” (32 MB) or also all assets included (+76 MB). Or all of it in a zip or rar (84 MB)?

How to send it?

There is no point in generating a package with a project that has all assets embedded as the assets are embedded in the file.

The package function is designed to aid projects that do not have assets embedded.