External Monitor Strange Colors FIX

Hello all, I’m just sharing here something I had to do to fix my blur colors and no gray colors in my external monitor.

So what happened from long time ago with my external monitor is that I have to calibrate colors manually, then change contrast, change bright and a lot of configurations, to make my external monitor image “acceptable”, but not even close to the image that I get from my Apple TV in the same monitor. And I try a LOT of different stuff even color profiles, etc. and never ever fix this until now (Thank you COVID-19).

So I start to digging what can be, and find that my MBP send image colors in Y’CbCr and my external monitor does’t decrypt that kind of color (even if is in VGA or HDMI cable) and I consider this monitor recent (2 years -> After my MBP).
So ok, I start trying some options and find a solution that works like a charme… :laughing:

So I share in here the option that works, and who knows it fix yours too, if you have this issue. (And finally you will see grays and no blur texts or shadows):

  1. Download this script: https://gist.github.com/adaugherity/7435890
  2. Place the patch-edid.rb file into the /Users/ directory
  3. Run this command in Terminal: ruby /Users/patch-edid.rb
  4. Take note of the DisplayProductID and DisplayVendorID file names. These will vary based on your monitor. (attention that is not the numbers on top but the result numbers in the end):
  5. Move the output file named “DisplayProductID-XXXX” from /Users/~username/ to the /Users/ directory
  6. Reboot your Mac in Recovery Mode by pressing Command+R as soon as you see the Apple logo after rebooting
  7. Open Disk Utility in Recover Mode
  8. Check to see if “Macintosh HD” is mounted. If it isn’t you will need to mount it before proceeding.
  9. Exit Disk Utility
  10. Open Terminal in Recovery Mode
  11. Run this command in Terminal (make sure to include spaces):

cp /Volumes/Macintosh\ HD/Users/DisplayProductID-XXXX /Volumes/Macintosh\ HD/System/Library/Displays/Contents/Resources/Overrides/DisplayVendorID-XXXX
(In my case: ProductID-23c1 (this one automatically fills with the tab key) and DisplayVendorID-469)

  1. Restart computer and the monitor should now be in RGB mode.

You know this in two ways:

  1. Open monitor preferences and in the window that you change the resolution of the external monitor you will find in the header the reference to "forced RGB mode (EDID override):
  2. In the app “color meter” when you move the app to the external monitor you will see:
    image

Hope it will help someone that is (was) in my case…

2 Likes

That’s great! Thanks for sharing!

1 Like

Nice @Pealco, does this work with Catalina?

It’s very strange that your MBP is sending information that is not automatically converted to RGB if needed by the external display. I have done quite a lot of work with colour management and never encountered this before, so it sounds like an obvious bug.

I would have thought hardware calibration using something like an i1Display Studio would have taken care of this automatically. That would identify the display type, calibrate and then save an RGB profile to your computer.

Yes I’m using Catalina and used this in my one, the normal one not the other from the other post.

No after Mojave that not happens, don’t know why, but always have this issue in upgraded OS and yesterday from a fresh Catalina install from a new OS from recovery download…

This happens in other friends computers…

OK That’s curious, I am on Mojave here but have a new Mac mini arriving with Catalina in a few days.

If this was a wide spread problem though I think I would have heard of it before now. My daughter has a 2018 MBP running Catalina that hooks up to an external display via HDMI with no colour issues.

Are you sure? I’m just asking this as at “normal” eyes there is no “big” issue, but if you have gray colors and little font in my case it gets very difficult to see.

But it could be just in specific brands, Asus or something like that…

My daughter is working in Maya all day long and if there was a problem we would have seen it.

Well I read in a few articles that this issue is only for some not all…
It could be by the brand of the external monitors, or something, I was affected about this (issue/bug/problem/etc) :relaxed:

Probably the users in here can share if some have or not this issue…

2 tips for managing resolutions for folks that don’t know yet.

In Monitor settings, Hold ‘alt key’ while clicking “scaled” opens all resolutions available for your monitor + 60hz switch when screens stuck at 30hz
(here in French but you got the point).

Another cool tool is SwitchResX for multi monitors managing with layers, + lots of cool features. Really handy.

1 Like