Font not loading on mobile [SOLVED]

Hello, fellow Blocs users,

First off, I love Blocs and have been using it since Blocs 2. It has been a lifesaver for me since the Muse ‘incident’ and cannot say enough about how much I appreciate everybody here at Blocs, the forum community, Norm, etc.

My issue is happening on a recently published website: the fonts are not loading correctly on mobile or tablet, and they are replaced by default fonts. When visited from desktop, everything looks fine and even using Responsinator and Chrome Developer Tools, the font displays correctly on every size. But when visited from a tablet or mobile device, the font is replaced by a default serif font. I’m a graphic designer with little to practically zero coding knowledge, or CCS or anything, and basically I don’t know how to solve it. The website is this:

http://elcaminoaaztlan.com/

I’d really appreciate any help.
Thanks in advance and keep on rockin’!
Alberto

It’s rather late to look at this in detail but have you used the same fonts at smaller breakpoints in project settings?

Hello Flashman,

Thanks for your quick reply. I left them as inherited. Maybe assigning them the font on all breakpoints could solve it? I’ll try that and will inform back.

Thanks again!
Alberto

Unfortunately didn’t work. I assigned fonts to all breakpoints instead of leaving them as inherited but no luck. Maybe something to do with the server? It is uploaded also to a temporary server used for testing purposes and everything looks fine there.

http://elcaminoaaztlan.com.s224858.gridserver.com/

Thanks again for any tip or pointer.
Cheers,
Alberto

Maybe a cache issue?

The fonts look the same for me on my phone and laptop.

Hi Malachiman!

Thanks for your reply. From that temporary site it looks good as you mention, but from the ‘real’ domain (found in my original post up there) is where the issue happens.
I’ve tried the cache and used two different devices but nope.

Thanks for looking!
Cheers,
Alberto

Oh right, I see I was looking at the wrong link.

Yep same font issue.

The real domain shows the same issue for me (wrong fonts on desktop too), looks like your fonts are not loading/missing

Oh wow! Ok, let me look into it. According to me I uploaded them. I’ll inform back.

Thanks man!

Alberto

Bingo! 3000 points to Mr. Malachiman! Thanks for pointing that out, I wouldn’t have known where to look.

As the site was uploaded through a cPanel, and such thing cannot upload folders with content (css, js, fonts, images, etc), I created a folder for each of these items to replicate the exported files and folders from Blocs and upload the files to their correspondent folder. Now, the font folder exported from the Blocs file had the font-awesome files plus folders for each variation of the montserrat font. My mistake was to not create a folder for each font variation and upload accordingly, replicating the exported files. Now that I placed each variation within their own folder within the fonts folder, it all works great.

Once again, thanks a lot Malachiman and Flashman for your support. You should look into forming a dynamic duo, already you have the superhero names :wink:

Cheers guys!
Alberto

1 Like

:zipper_mouth_face:

Your secret identity is safe with me.

1 Like