Font settings ignored on WP Theme export

Hi, as I’m testing quite avidly, I’m running into an issue where I’m seeing my font settings being ignored completely.

I’ve set my logo, site title and tagline (and every other title) to typeface “Lobster”, while general text is set to “Roboto”. In the Project Settings I’ve got typeface set to “Roboto”.
However, when exported, I’m seeing Helvetica being used everywhere.

The site is live on (just a testing environment).

Might not be related, but while I’ve set the CMS to WordPress on creation of this new project, when adding a page, I do not get the WordPress page selector.

Anyone got any pointers to what I’m doing wrong? Or did I run into a bug?

In my case I set the fonts in project settings that were added locally. It all worked as expected.

For the WP selector when adding a new page are you clicking the WP icon to select the type? I missed this at first.

Screenshot 2020-12-05 at 15.46.02

1 Like

Double check in project settings that Wordpress is assigned as the CMS.

1 Like

I’m actually missing this little “WordPress” button:

I would do as Norm suggested then and check to see the project is actually set as WordPress for the CMS, otherwise you are just getting normal Blocs pages.

1 Like

It is, yet still no WordPress button:

That’s odd. Possibly a bug. This is definitely Blocs Plus?

Try setting the cms to none and then back to Wordpress again.

Try restarting Blocs if that fails send in a copy of the project file and I’ll see why that’s happening.

1 Like

Setting CMS to “none” in the project settings and then back to “WordPress” fixed it. I’ve got my button back.

Thanks for the swift solution. And also thanks for building such a great tool. Fastest I’ve ever been able to craft a custom theme. :heart_eyes:

I’ve now re-exported the theme so far, but it seems the font issue is still persistent. I’ve added both the theme project file and generated theme (work in progress). (1.9 MB) fontissue.bloc (2.9 MB)

1 Like

I’ll take a look on Monday :+1:

1 Like

Great, thanks. Have an amazing weekend!

1 Like

Hi @Norm, would you happen to have found the reason for this behavior?