Font sizes in 2.6.1

Anybody else noticed in 2.6.1 that when setting font sizes in project settings that they are only being correctly observed in desktop mode? For example, if I decide to change an H4 tag from 24 pt to 20pt this is completely ignored in tablet and mobile, forcing me to change them manually in the side panel. The same problem is also occurring with colour choices not transferring to tablet or mobile and I’ve been forced to rely on custom classes.

Rem settings for font sizes in project settings also seem to behave very weirdly. I can set H4 tags as 2 rem with the line height as 2.5 rem, but when I click on a h4 header it will show up in the side panel 20px for size and 25px for line height.

The project settings applies globally, editing the values while in a breakpoint does not work.

In a New project set the font size to 50 in project settings, this is now set for all text objects across all breakpoints. If you need to change it for a specific breakpoint, find the class relevant to that text tag in the class manager and edit it while in the target breakpoint.

If I go to project settings and change the size from 40 to 50 it has no effect on tablet or mobile now. They remain as they were, so they are not global at all.

Also if I set a H5 header colour to say light blue that colour will only be applied in desktop mode, whereas it might appear as grey when viewed on mobile or tablet. This was never the case previously.

Did you try a new project, to rule out custom class overrides?

I just did and it worked as expected.

This has only happened since starting a new project in 2.6.1. I sent in a support ticket with a project file on the colour issue last week.

Do you get it with a fresh project?

That was a fresh project started in 2.6.1, but I’ll try again now with something completely new. At the moment I’m working on an older project started under 2.5 and struggling in the same way with the font sizes.

I don’t have a copy of the file in the ticket system. It sounds like you have classes overriding the global text ones, inline styles (set via the sidebar) applied to text objects will override global text classes.

Go to a problematic text object and clear its inline text styling, little x in the top right corner of the text sidebar inspector options


Just tried that the problem remains if I remove the custom class.

are these the h5 items?

Yes on the services page, but I had the same problem elsewhere as well, which also required a custom class to work properly on on tablet or mobile.