Footer icons gone

OK,
I have 8 standard feather icons hyperlinked to social sites in my footer. Background is white, icons are black. The footer is coming up white with no icons. No hidden hyperlinks either. Screencap shows details.I had the earlier icon problem which remains unsolved. See here: http://bburgess.com/

I got Blocs to get past the Adobe Muse hate machine. Now I’m not sure. I’m using Blocs 3.4.1.
Thanks All…

You still are having a 403 error on the page, again for the icons.

This could be a server issue on your host end. Maybe @Pealco or @Flashman have some insight into this?

I think it can be related to file / directory permissions. But then the other style sheets load, so I don’t know?

If you are using 3.4.1 I would first try updating, because there have been nine more updates and the current version is 3.4.10. It should work with either version but if a bug is present it will be easier to troubleshoot when testing with the latest version. Looking at that 403 code it does appear likely this is a server issue. If you save the bloc in question and post it here we can take a look.

Joust a thought… I assume you have tried removing all files from the server, then uploading again after publishing form Blocs? Of course, making sure any config files like htaccess are saved soemwhere.

Thanks @Malachiman @Flashman @Hypnoman ,

Flashman my mistake. I wrote that post at 2 in the morning. I actually am using 3.4.10.
The other thing I realized this morning is that Chrome is showing the icons as expected. http://www.bburgess.com/ But not Safari, Firefox or Opera.

If Chrome displays the footer icons and their embedded hyperlinks correctly doesn’t that eliminate any server side issues?
I wasn’t sure how to export or save a single block so I made a new Bloc document with just the footer, exported it and posted the zip here. bburgess footer bloc icon troubleshoot.zip (741.9 KB)

Heck I’m way beyond my skills here, way way out in the deep end compared to you guys. Really appreciate the community for the generous help…

I just looked at your site with Chrome (Mac) and it does not show footer icons for me. It’s giving 403 errors (forbidden), similar as with Safari. Like @Malachiman suggested, maybe check with your web service provider support that all font files are loaded in the css folder with proper readable file permissions (mine is 0644), or ask a tech friend for help.

Thanks @pruthe. I’m on hold with GoDaddy as we speak. When I look at my Blocs export everything in the css and fonts folders have a file creation date of 3/17/20. Shouldn’t those fonts and css files export with the date I did the export from Blocs?

I also checked permissions for each of those files in the Blocs export folder. They are all set to admin/read/write. Scratching my head

The most frequently used phrase in the world of web hosting.

1 Like

Just make sure everything that’s in the Blocs export folders (in this case the css folder) are also in the web site install folders. Good Luck and keep hanging in there finding the solution! :slight_smile:

Ok…
Success. At the server level I had to change permissions of every exported Blocs folder to 755 and every file within those folder to 644. The process is a “select all” click “Permissions” then switch the number. Critical that the user/builder of the site always has read/write permissions enabled or they will have to “rekey” their server which is an admin mind f&*k.

I hope this hard-won knowledge will help anyone trying to host their first Blocs project with GoDaddy hosting. THANK YOU Everyone…

Your website is not GDPR compliant without the SSL certificate. That’s a potential problem.

New SSL certificate issued and migrating. What is GDPR?

It’s a very heavy handed law from the EU centred on data protection and privacy that extends to anybody dealing with citizens within the EU. That is why the likes of Apple and Google have to comply if they wish to provide services to EU consumers.

Way to go in fixing problem! :slight_smile:

p.s. I’m also able to access via https.

https://www.bburgess.com/

So cool! Thanks!!

You have four versions of the site, which is not good for SEO or security. Try driving them all to a single version. I always use https:// as detailed here

1 Like