Google Analytic code is visible in the browser -- SOLVED

Hi --After I placed my Google Analytic code in the ‘Analytics Tracking code’ box of the Project Settings, I noticed when viewing the site in the preview browser that I can see the code rendered above the top navigation in a white area in the upper left corner.

I then removed it from the Project Settings, and I tried placing it in the Page Settings in the Add Code, under Header, and got the same results. [it’s redacted in the screen capture, but that’s the number)

Any guidance would be appreciated…TIA

A link to the page please…


Thanks InStacks – The page in not live yet, still in the design process, almost complete, viewable only in Blocs and using the Preview in Browser option, which is what the screen capture is from.

Any thoughts?

Can you post the code you use here?

HI – It’s just the Google Analytic address for my site…no real ‘code’…you know the one you get from google in order to track activity on your site which gets posted on your google dashboard.

Btw, my site is hosted on a commercial hosting service, do you know if there is a way to upload by Bloc’s project for viewing without making it ‘public’…if so, then I could try that and send a private link (i.e. keep my current site live, and share the one in progress from Blocs…?)

Like with a sub domain.

ah, I think I understand. Is this correct: my host server has a ‘Public’ directory for my live website, but if I set up a separate directory, perhaps calling it ‘test’ or ‘private’ (or whatever) and then I upload my Blocs projects to that directory, I can then view my blocs project ‘privately’ and also share a link to it to whomever I needed to? Is that how it works. I’m not a techie but I’m a pretty good learner if well guided.

okay…got a sub-directory set up to view the site.

Here’s the link:

You will see the Goggle ID in the upper left corner in a white space that also shouldn’t be there…

Thanks for helping out with this. Maybe this is a bug with 3.2.3?

Hey @DanielF

Can you post a screenshot of your Project Settings >Analytics Tracking Code

Cheers / Johny

All solved. I only had the ID in the ‘Analytic Tracking Code’ box, and not the full ‘code snippet’ which I didn’t know was needed. Just found it on the Google, and pasted it, and now all is well…thanks to all for your support. :pray:t3:


Hi @DanielF,

It looks that your contact form header has some kind of hover margin applied and it jumps very strange. I think it wasn’t intentional by you.

I see you are making a lot of progress with Blocs! :slight_smile: Great job!


1 Like

Thanks Eldar, I’ll see what I’ve done, as it should not ‘jump’…I appreciate your feedback and all your guidance during my learning process. :slight_smile:


Yes…you were spot on, I had a margin inconsistency between ‘normal’ and ‘hover’…all fixed now! :pray:t3:

1 Like