Got an M1 Mac? Can you try this please?

My website works fine on my Intel Macs.

But on my M1 MacBook Air it does not, no matter which browser I try… the top global menu on the homepage is inactive until the page is scrolled, however slightly. Other pages are fine.

I have a ticket open for this with @Norm, but would appreciate any extra info on where my website doesn’t work…


It’s working fine on my M1 Mac mini

Good to know! :+1:

Looks OK on my M1 Mac Mini.

I have a MBP intel and see what you referring in home page it don’t allow me to use the menu on top unless I scroll 1px down, in the other pages without scroll I can use the menu.

Oh no! I thought it would just be an Apple silicon issue as that’s when it started for me.

Thanks for the info though, hopefully it will help @Norm

@pruthe Good news! :+1:

I see the bug on the home page only on my MacBook Air M1 8Gb 512Gb.

Thanks @raybb3uk

This pretty much confirms it’s a laptop issue.

I’ve tried it on two Intel Macs belonging to friends, and the bug is there.

So not an Apple Silicon issue after all.

@Norm, I’ve made some changes, like unticking Sticky, and removing the Menu from the top Global Area and then putting it back again.

No change.

I don’t know what else I can do, can you help?


Update I’ve also deleted the Menu from the homepage, and copied and pasted a working menu from another page.

It still doesn’t work. There’s some sort of homepage menu issue it seems.

@Norm Another update. I’ve discovered that on the homepage only the links have separated from the text in the top menu - they have moved above the text. Any ideas please?

@Norm - anything? I’ve had two tickets open with you for a month.

Sorry for the delay, it’s been Christmas and our office was closed for some of that time so there are currently some delays.

Now 4.0.4 is out with a range of critical fixes for M1 more tests and fixes will be rolled into the first beta of Blocs 4.1 which will be available as beta 1 on Friday.

BTW have you checked your custom classes, it sounds like a class may be causing some issues. I’ll have more details soon

Not sure how custom classes can affect the same global menu differently on different pages, and on different computers.

Desktops work fine, as far as I can tell. Laptops don’t work at all.

Have sent the project as requested, it’s way beyond my pay grade!

1 Like

It is a class issue, I’ve sent a few solutions.

Sorry for the delay

Thanks Norm, the z-index solution works perfectly.

If only I knew what the flip it is… I’ll check the documentation.

Thanks again, appreciated!

1 Like

No problem, again apologies for the delay :+1:

Not able to run on a Mac Book Pro with M1, not sure why…